Subject: no Xorg... chrome failes

From: Riccardo Mottola <[email-masked]>
Date: Tue, 31 Mar 2020 00:31:23 +0200

Hi all!

I am unable to start X. It get backs to console with some garbled 
messages and (EE) no screens found.

It also says something about
xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted) 
but I don't see that line in Xorg.log

In the Xorg.log, I do see:

[    88.460] (WW) Falling back to old probe method for modesetting
[    88.460] (EE) open /dev/dri/card0: No such file or directory
[    88.460] (II) CHROME(0): viaPreInit
[    88.460] (II) CHROME(0): VIAGetRec
[    88.460] (--) CHROME(0): Chipset: KM400 / KM400A / KN400 / P4M800
[    88.460] (--) CHROME(0): Chipset revision: 0
[    88.658] (EE) CHROME(0): [drm] Failed to open DRM device for 
pci:0000:01:00.0: No such file or directory
[    88.658] (II) Loading sub module "vgahw"
[    88.658] (II) LoadModule: "vgahw"
[    88.659] (II) Loading /usr/lib/xorg/modules/libvgahw.so
[    88.677] (II) Module vgahw: vendor="X.Org Foundation"
[    88.677]    compiled for 1.20.5, module version = 0.1.0
[    88.677]    ABI class: X.Org Video Driver, version 24.0
[    88.677] (--) CHROME(0): Probed amount of VideoRAM = 65536 kB
[    88.677] (II) CHROME(0): Entered viaMapMMIO.
[    88.677] (--) CHROME(0): Mapping MMIO at address 0xD1000000 with 
size 52 KB.
[    88.677] (--) CHROME(0): Mapping 2D Host BitBLT space at address 
0xD1200000 with size 2048 KB.
[    88.677] (--) CHROME(0): Mapping the frame buffer at address 
0xF0000000 with size 65536 KB.
[    88.678] (--) CHROME(0): Frame buffer start address: 0xb34bc000, 
free start: 0x0 end: 0x4000000
[    88.678] (II) CHROME(0): Entered viaMMIOEnable.
[    88.678] (II) CHROME(0): Exiting viaMMIOEnable.
[    88.678] (II) CHROME(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0
[    88.678] (II) CHROME(0): Exiting viaMapMMIO.
[    88.678] (II) CHROME(0): Creating default Display subsection in 
Screen section
         "Default Screen Section" for depth/fbbpp 24/32
[    88.678] (==) CHROME(0): Depth 24, (--) framebuffer bpp 32
[    88.678] (==) CHROME(0): RGB weight 888
[    88.679] (==) CHROME(0): Default visual is TrueColor
[    88.679] (II) CHROME(0): VIASetupDefaultOptions - Setting up default 
chipset options.

this is the last error I see, then a lot of information about the chrome 
driver.

Any suggestions?

Riccardo

---

From: Natanael Copa <[email-masked]>
Date: Tue, 31 Mar 2020 11:15:42 +0200

On Tue, 31 Mar 2020 00:31:23 +0200

> [    88.460] (WW) Falling back to old probe method for modesetting
...

> this is the last error I see, then a lot of information about the chrome 

Do you have the openchrome driver installed?

 apk add xf86-video-openchrome