Subject: [alpine-user] dri errors

From: Riccardo Mottola <[email-masked]>
Date: Thu, 10 May 2018 01:27:44 +0200

Hi,

when launching many programs, among firefox but even just x 
screensavers, I see these errors:

MESA-LOADER: failed to retrieve device information
unknown chip id 0x5460, can't guess.
libGL error: failed to create dri screen
libGL error: failed to load driver: radeon
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

This I see in dmesg:
[   10.555001] [drm] radeon: 64M of VRAM memory ready
[   10.555003] [drm] radeon: 512M of GTT memory ready.
[   10.555007] [drm] GART: num cpu pages 131072, num gpu pages 131072
[   10.555886] [drm] radeon: power management initialized
[   10.555908] [drm] radeon: 1 quad pipes, 1 Z pipes initialized.
[   10.556975] [drm] PCIE GART of 512M enabled (table at 
0x00000000C0040000).
[   10.557015] radeon 0000:01:00.0: WB enabled
[   10.557019] radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 
0x00000000a0000000 and cpu addr 0xff8d4000
[   10.557023] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[   10.557024] [drm] Driver supports precise vblank timestamp query.
[   10.557026] radeon 0000:01:00.0: radeon: MSI limited to 32-bit
[   10.557085] radeon 0000:01:00.0: radeon: using MSI.
[   10.557109] [drm] radeon: irq initialized.
[   10.557112] [drm] Loading R300 Microcode

Reading in the forums and searching I guess it might be an issue to DRI 
access?

However I am confused, this is dri:

t43alpine:~$ sudo ls -l /dev/dri/
total 0
drwxr-xr-x    2 root     root           100 May  9 23:57 by-path
crw-rw----    1 root     video     226,   0 May  9 23:57 card0
crw-rw----    1 root     video     226,  64 May  9 23:57 controlD64
crw-rw----    1 root     video     226, 128 May  9 23:57 renderD128

and I set my user part of the video group (adding myself in /etc/group) 
which I can prove:

t43alpine:~$ groups
multix wheel audio cdrom video cdrw usb

So what??? Thanks in advance!

Riccardo

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Cág <[email-masked]>
Date: Thu, 10 May 2018 11:06:52 -0400

Riccardo Mottola wrote:

> when launching many programs, among firefox but even just x screensavers, I
> see these errors:
> 

Do you have xf86-video-ati installed?

-- 
caóc

---

---

From: Riccardo Mottola <[email-masked]>
Date: Fri, 11 May 2018 00:16:52 +0200

Hi!

> Do you have xf86-video-ati installed?

Yes, according to apk info, I have it installed, as well as mesa-dri-ati

I suppose without, xf86-video-ati Xorg would run worse on fbdev or not 
start at all.

Riccardo

---

---

From: Cág <[email-masked]>
Date: Fri, 11 May 2018 17:11:50 -0400

Riccardo Mottola wrote:
 
> I suppose without, xf86-video-ati Xorg would run worse on fbdev or
> not start at all.

Ok then, what if you manually configure Xorg to use the radeon driver
in xorg.conf? Like this:

----
Section "Device"
	Identifier "Radeon"
	Driver "radeon"
EndSection
----

-- 
caóc

---

---

From: Riccardo Mottola <[email-masked]>
Date: Mon, 14 May 2018 20:56:34 +0200

Hi Cág,

Cág wrote:
> in xorg.conf?

I am pretty sure the radeon driver is already correctly loaded and used.
I attach the Xorg log.
Something is not working with GL. First thing. access to the dri device.

I notice also that GLX gets loaded:

[    59.168] (II) LoadModule: "glx"
[    59.169] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    59.479] (II) Module glx: vendor="X.Org Foundation"
[    59.480]     compiled for 1.19.6, module version = 1.0.0
[    59.480]     ABI class: X.Org Server Extension, version 10.0

This testifies Radeon is getting loaded, or?

[    59.909] (==) RADEON(0): Depth 24, (--) framebuffer bpp 32
[    59.909] (II) RADEON(0): Pixel depth = 24 bits stored in 4 bytes (32 
bpp pixmaps)
[    59.909] (==) RADEON(0): Default visual is TrueColor
[    59.909] (==) RADEON(0): RGB weight 888
[    59.909] (II) RADEON(0): Using 8 bits per RGB (8 bit DAC)
[    59.909] (--) RADEON(0): Chipset: "ATI Radeon Mobility X300 (M22)" 
(ChipID = 0x5460)

Later there are a ot of errors of this kind, I bet they are not related 
to GL not working for me.. though.

[    64.337] (II) This device may have been added with another device file.
[    64.337] (II) config/udev: Adding input device (unnamed) (/dev/tty10)

Riccardo

---

From: Cág <[email-masked]>
Date: Tue, 15 May 2018 12:56:23 -0400

Ok, so it's not a Xorg problem. It could be a bug with Mesa; searching
the Web only gives answers like "upgrade Mesa". Have you tried any
programs that rely on it? Like mplayer maybe. I wonder if performance
suffers.

What do other distros on this machine with other versions of Mesa say?
Have you seen such errors before? 

--
caóc

---

---

From: William Pitcock <[email-masked]>
Date: Tue, 15 May 2018 23:15:47 -0500

Hello,

> Have you seen such errors before?

What does

  env LIBGL_DEBUG=verbose glxinfo

say?

Also, using the GPU should always succeed as root.

William

---

---

From: Riccardo Mottola <[email-masked]>
Date: Fri, 18 May 2018 00:10:22 +0200

>    env LIBGL_DEBUG=verbose glxinfo

t43alpine:~$ env LIBGL_DEBUG=verbose glxinfo
name of display: :0
MESA-LOADER: failed to retrieve device information
libGL: OpenDriver: trying /usr/lib/xorg/modules/dri/radeon_dri.so
libGL: Can't open configuration file /etc/drirc: No such file or directory.
libGL: Can't open configuration file /home/multix/.drirc: No such file 
or directory.
unknown chip id 0x5460, can't guess.
libGL error: failed to create dri screen
libGL error: failed to load driver: radeon
libGL: OpenDriver: trying /usr/lib/xorg/modules/dri/swrast_dri.so
libGL: dlopen /usr/lib/xorg/modules/dri/swrast_dri.so failed (Error 
loading shared library /usr/lib/xorg/modules/dri/swrast_dri.so: No such 
file or directory)
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
X Error of failed request:  GLXBadContext
   Major opcode of failed request:  155 (GLX)
   Minor opcode of failed request:  6 (X_GLXIsDirect)
   Serial number of failed request:  49
   Current serial number in output stream:  48

> Also, using the GPU should always succeed as root.

To test this further, I installed mesa-demos and use the typical 
glxgears, much easier to test than seeing erros within midori, 
xscreensaver or other apps.

Here is the output if run as normal users:

t43alpine:~$ glxgears
MESA-LOADER: failed to retrieve device information
unknown chip id 0x5460, can't guess.
libGL error: failed to create dri screen
libGL error: failed to load driver: radeon
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
X Error of failed request:  BadValue (integer parameter out of range for 
operation)
   Major opcode of failed request:  155 (GLX)
   Minor opcode of failed request:  3 (X_GLXCreateContext)
   Value in failed request:  0x0
   Serial number of failed request:  36
   Current serial number in output stream:  38

However:
t43alpine:~$ sudo -E glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
278 frames in 5.0 seconds = 55.490 FPS
278 frames in 5.0 seconds = 55.559 FPS
278 frames in 5.0 seconds = 55.562 FPS

this confirms my hypothesis that all drivers are there and do work, it 
is an issue with device access and you are right: it succeeds as root.

without vblank I get excess of 600 fps, so... nice that.

The issue appears access to dri..

Riccardo

---