Subject: [alpine-user] dropbear-dbclient

From: Vieri <[email-masked]>
Date: Wed, 5 Jun 2019 09:03:32 +0000 (UTC)

Hi,

I'm new to Alpine.

I have one quick and easy question. I installed dropbear, but I can't seem to find dbclient anywhere. According to https://build.alpinelinux.org/buildlogs/build-edge-aarch64/main/dropbear/dropbear-2019.78-r0.log, dbclient should be in /usr/bin, but it isn't.

Also, according to the wiki (https://wiki.alpinelinux.org/wiki/Setting_up_a_ssh-server#Dropbear) dbclient should be available.

Any thoughts?

Vieri

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Marco Dickert <[email-masked]>
Date: Wed, 5 Jun 2019 12:12:11 +0200

Hi,

> Also, according to the wiki (https://wiki.alpinelinux.org/wiki/Setting_up_a_ssh-server#Dropbear) dbclient should be available.

it's in a subpackage:

```
$ apk install dropbear-dbclient
```

You can search for specific paths with pkgs.alpinelinux.com [1].

[1] https://pkgs.alpinelinux.org/contents?file=dbclient&path=%2Fusr%2Fbin&name=&branch=edge

-- 
Marco Dickert
[email-masked]
https://misterunknown.de

---

From: Vieri <[email-masked]>
Date: Wed, 5 Jun 2019 10:33:28 +0000 (UTC)

On Wednesday, June 5, 2019, 12:12:16 PM GMT+2, Marco Dickert <[email-masked]> wrote: 
>
> It's in a subpackage:
> 
> $ apk install dropbear-dbclient```
>

Right, my bad. I was searching for "dropbear" when I should've searched for "dropbear*"...

Thanks,

Vieri

---