Subject: Problems with mkinitfs on 3.12.0

From: Thomas Trepper <[email-masked]>
Date: Sun, 7 Jun 2020 18:34:35 +0200

Hi all, 

I am trying to the Alpine installed like described here: https://wiki.alpinelinux.org/wiki/LVM_on_LUKS

which was working fine for 3.11.2. I am now trying 3.12.0 and I have problems with mkinitfs command. What I do is: 

[… some steps before …]

setup-disk -v -m sys /mnt/
Root device:     /dev/mapper/VG_SSD_RAID-LV_ROOT
Root filesystem: ext4
Boot device:     /dev/sda1
Boot filesystem: ext2
Installing system on /dev/mapper/VG_SSD_RAID-LV_ROOT:
/mnt/boot is device /dev/sda1
100% ######################################################################################################################################################################################################==> initramfs: creating /boot/initramfs-lts
/boot is device /dev/sda1
You might need fix the MBR to be able to boot

alpine:~# df -h
Filesystem                Size      Used Available Use% Mounted on
devtmpfs                 10.0M         0     10.0M   0% /dev
shm                     351.5M         0    351.5M   0% /dev/shm
/dev/sr0                124.0M    124.0M         0 100% /media/cdrom
tmpfs                   351.5M    327.3M     24.2M  93% /
tmpfs                    70.3M    168.0K     70.1M   0% /run
/dev/loop0               89.9M     89.9M         0 100% /.modloop
/dev/mapper/VG_SSD_RAID-LV_ROOT
                          4.9G    835.9M      3.8G  18% /mnt
/dev/sda1               387.4M     24.9M    342.5M   7% /mnt/boot

alpine:~# lsblk 
NAME                      MAJ:MIN RM  SIZE RO TYPE  MOUNTPOINT
loop0                       7:0    0 89.8M  1 loop  /.modloop
sda                         8:0    0   10G  0 disk  
├─sda1                      8:1    0  400M  0 part  
├─sda2                      8:2    0  6.5G  0 part  
│ └─sda2_crypt            253:0    0  6.5G  0 crypt 
│   └─VG_SSD_RAID-LV_ROOT 253:2    0    5G  0 lvm   
└─sda3                      8:3    0  3.1G  0 part  
  └─sda3_crypt            253:1    0  3.1G  0 crypt [SWAP]
sr0                        11:0    1  124M  0 rom   /media/cdrom

alpine:~# vi /mnt/etc/crypttab (adding lines etc)
alpine:~# vi /mnt/etc/fstab
alpine:~# vi /mnt/etc/mkinitfs/mkinitfs.conf

[======== here is my problem ========]
alpine:~# mkinitfs -c /mnt/etc/mkinitfs/mkinitfs.conf -b /mnt/ $(ls /mnt/lib/modules/)
==> initramfs: creating /mnt/boot/initramfs-lts
cpio: write error: No space left on device

alpine:~# df -h
Filesystem                Size      Used Available Use% Mounted on
devtmpfs                 10.0M         0     10.0M   0% /dev
shm                     351.5M         0    351.5M   0% /dev/shm
/dev/sr0                124.0M    124.0M         0 100% /media/cdrom
tmpfs                   351.5M    327.3M     24.2M  93% /
tmpfs                    70.3M    168.0K     70.1M   0% /run
/dev/loop0               89.9M     89.9M         0 100% /.modloop
/dev/mapper/VG_SSD_RAID-LV_ROOT
                          4.9G    835.8M      3.8G  18% /mnt
/dev/sda1               387.4M     24.9M    342.5M   7% /mnt/boot

Am I missing something? Any help or hints are highly appreciated. Thanks a lot in advance, 
Thomas

---

From: Mogens Jensen <[email-masked]>
Date: Sun, 21 Jun 2020 07:48:34 +0000

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

> /mnt/boot is device /dev/sda1

Hi,

By default mkinitfs uses /tmp for temporary files and your / is 93%
full, so I think there is not enough space to create the initramfs. You
can specify another location that has more space with the -t option.

Regards,
Mogens Jensen