Subject: How do I download the source for Alpine Linux packages

From: "Michael Peters (mipeter3)" <[email-masked]>
Date: Wed, 28 Aug 2019 18:42:03 +0000

I'm trying to get the source packages for various Alpine packages that are installed on my images (for compliance reasons) and I'm having trouble tracking them down.

For instance, I have alpine-baselayout-3.1.2-r0 installed and I can see the package details<https://pkgs.alpinelinux.org/package/edge/main/x86/alpine-baselayout> and it links to the git repo, but it's to the aports tree which has the APKBUILD file and things needed to build the apk files (and source packages) but not the package itself. I was also able to find the APK package itself<http://dl-cdn.alpinelinux.org/alpine/latest-stable/main/x86/alpine-baselayout-3.1.2-r0.apk>, but searching that tree does not give a source package. And then looking at https://git.alpinelinux.org/alpine-baselayout/ I can see several older packages that appear to be source packages (but maybe just git tree snapshots), but nothing newer than 7 years.

So, how do I download the source packages for Alpine packages?
Thanks!

--
Michael Peters

---

From: Tuan Hoang <[email-masked]>
Date: Thu, 29 Aug 2019 19:34:37 +0200

alpine-baselayout is a little bit special. If you look at source= line
in its APKBUILD, you will see it contains only "local" files (local to
the APKBUILD). In another word, "source package" = APKBUILD + those
local files (crontab, color_prompt, etc.)

Other examples are alpine-base, alpine-mirrors, alpine-keys (anyone else?).

On 8/28/19 7:42 PM, Michael Peters (mipeter3) wrote:
> I'm trying to get the source packages for various Alpine packages that
> are installed on my images (for compliance reasons) and I'm having
> trouble tracking them down.
> 
> For instance, I have alpine-baselayout-3.1.2-r0 installed and I can see
> the package details
> <https://pkgs.alpinelinux.org/package/edge/main/x86/alpine-baselayout> and
> it links to the git repo, but it's to the aports tree which has the
> APKBUILD file and things needed to build the apk files (and source
> packages) but not the package itself. I was also able to find the APK
> package itself
> <http://dl-cdn.alpinelinux.org/alpine/latest-stable/main/x86/alpine-baselayout-3.1.2-r0.apk>,
> but searching that tree does not give a source package. And then looking
> at https://git.alpinelinux.org/alpine-baselayout/ I can see several
> older packages that appear to be source packages (but maybe just git
> tree snapshots), but nothing newer than 7 years.
>

---

From: PICCORO McKAY Lenz <[email-masked]>
Date: Wed, 28 Aug 2019 20:08:45 -0400

El mié., 28 de ago. de 2019 a la(s) 14:42, Michael Peters (mipeter3) (
[email-masked]) escribió:

> it links to the git repo, but it's to the
>
alpine lower of the 3.4 are just too older and seems developers does not
archive at all... (and only thinks about fashion sources)

> aports tree which has the APKBUILD file and things needed to build the apk
> files (and source packages) but not the package itself. I was also able to
> find the APK package itself
> but searching that tree does not give a source package.
>
seems in the beggining all the guys maybe thing that always the sources
will be online...
the APKBUILD of each package take source mostly from network.. if those
sources are not online anymore.. sorry.. there's no source to retrieve

> And then looking at https://git.alpinelinux.org/alpine-baselayout/ I can
> see several older packages that appear to be source packages (but maybe
> just git tree snapshots), but nothing newer than 7 years.
>
source package for each package depends of the apk build file .. for most
olders you must see it at the alpine git repository.. due the previously
reason i told you now. some git repos were moved and others archived!

maybe ncopa tell something here!