Subject: [alpine-user] Unable to install 3.8 Samba package due to cross-dependency of packages [SB]

From: "Senior, Ian" <[email-masked]>
Date: Thu, 12 Jul 2018 12:27:47 +0000

Classification: Serco Business
Hello,

I am attempting to install Alpine Linux 3.8 aarch64 Samba onto an embedded system that does not have internet access.

I have manually loaded 80% of the packages required for samba, but have hit a roadblock at the following two packages

o   samba-common-libs-4.8.2-r1.apk

o   samba-client-libs-4.8.2-r1.apk

Unfortunately each of the above packages depends on the other, so I am unable to load either of them.

Is there another way I can get these loaded, or can you update the release with the "libevents-samba4.so" library moved out of the "samba-common-libs" package and into for example "samba-libs-4.8.2-r1.apk" which would break the cyclic dependency.

Regards
Ian

This e-mail and any attachments may contain confidential and
privileged information. If you are not the intended recipient,
please notify the sender immediately by return e-mail, delete this
e-mail and destroy any copies. Any dissemination or use of this
information by a person other than the intended recipient is
unauthorized and may be illegal.

---

From: Herry Herry <[email-masked]>
Date: Thu, 12 Jul 2018 13:58:22 +0100

Hi Ian,

To my knowledge, you can extract an APK package using tar. I would suggest to extract samba-common-libs-4.8.2-r1.apk at root directory, and then install samba-client.

Hope this helps.

Regards,
Herry

> On 12 Jul 2018, at 13:27, Senior, Ian <[email-masked]> wrote:
> 
> Is there another way I can get these loaded, or can you update the release with the “libevents-samba4.so” library moved out of the “samba-common-libs” package and into for example “samba-libs-4.8.2-r1.apk” which would break the cyclic dependency.
> 
> Regards
> Ian
> 

---
PGP key: FC28 2A0A BC36 27FE DF2C  A4FA A538 76B2 04C9 A359

---

From: Jakub Jirutka <[email-masked]>
Date: Thu, 12 Jul 2018 15:09:18 +0200

Hi Ian,

how do you install them? If you've downloaded the apk files and you have
working apk, then you should be able to install them using:

    apk add samba-common-libs-4.8.2-r1.apk samba-client-libs-4.8.2-r1.apk

Jakub

On 12/07/18 14:58, Herry Herry wrote:
> Hi Ian,
> 
> To my knowledge, you can extract an APK package using tar. I would
> suggest to extract samba-common-libs-4.8.2-r1.apk at root directory, and
> then install samba-client.
> 
> Hope this helps.
> 
> Regards,
> Herry
> 
>> On 12 Jul 2018, at 13:27, Senior, Ian <[email-masked]
>> <mailto:[email-masked]>> wrote:
>>
>> I am attempting to install Alpine Linux 3.8 aarch64 Samba onto an
>> embedded system that does not have internet access.
>>  
>> I have manually loaded 80% of the packages required for samba, but
>> have hit a roadblock at the following two packages
>> Is there another way I can get these loaded, or can you update the
>> release with the “libevents-samba4.so” library moved out of the
>> “samba-common-libs” package and into for example
>> “samba-libs-4.8.2-r1.apk” which would break the cyclic dependency.
>>  
>> Regards
>> Ian
>>  
>>

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---