Subject: [alpine-user] How can I upgrade kernel that USB installed alpine linux?

From: 김보겸 <[email-masked]>
Date: Sun, 26 Aug 2018 02:43:47 +0900

Hi,

I use alpine linux on raspberry pi.

This distribution is great and works good.

But I have a question…

I make scared image from ISO files.

Kernel and firmware, modules are in USB not a part of packages.

So how can I upgrade kernel?

Wait until next release?
Or alpine-iso script?

How can I upgrade  kernel that USB installed alpine linux?

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Cág <[email-masked]>
Date: Mon, 27 Aug 2018 15:00:19 -0500

> How can I upgrade  kernel that USB installed alpine linux?

Why not just compile your own? You have a config-* file, just copy it
and build.

--
caóc

---

---

From: 陈杨文 <[email-masked]>
Date: Mon, 27 Aug 2018 09:43:49 +0800

Do you try install linux-rpi ? this will install the kernel, then manually
update syslinux config may do the trick. I use to update my 3.7 alpine
installed on usb to 3.8. Changed the harden kernel to vanilla
https://github.com/wenerme/wener/blob/master/tricks/ops/os/alpine/README.md#38