Subject: Install dependencies

From: [email-masked]
Date: Thu, 30 Mar 2023 09:57:40 +0200

Hi Carlo, all,

I'd like to run Drakon on my Alpine 3.17, aarch64 raspberry pi.

https://github.com/stepan-mitkin/drakon_editor names as dependencies the 
ubuntu packages:

$ sudo apt-get install tcl8.6 tk8.6 tcllib libsqlite3-tcl libtk-img

I found

$ sudo apk add tcl tk sqlite-tcl

and am ready to compile tkimg from source. But what about 
https://pkgs.alpinelinux.org/packages?name=tcllib?

Greetings,
Marcus

---

From: "alice" <[email-masked]>
Date: Thu, 30 Mar 2023 10:22:48 +0200

> https://pkgs.alpinelinux.org/packages?name=tcllib?

tcl-lib, probably

---

From: [email-masked]
Date: Thu, 30 Mar 2023 10:50:50 +0200

On 30 Mar 2023, at 10:22, alice wrote:

>> ... what about https://pkgs.alpinelinux.org/packages?name=tcllib?
>
> tcl-lib, probably

indeed, meanwhile I am at

$ sudo apk add build-base tcl-dev tcl-lib tk-dev sqlite-tcl tiff-
dev

and run into make compilation errors:

$ ./configure.sh
...
$ make
...
../compat/libtiff/libtiff/tiffio.h:511:48: error: unknown type name 'uint32'; did you mean 'uint16'?
  511 |                            uint32 *, uint32 *, uint32 *);
      |                                                ^~~~~~
      |                                                uint16
In file included from tifftclDecls.h:38:
../compat/libtiff/libtiff/tiffiop.h:33:10: fatal error: tif_config.h: No such file or directory
   33 | #include "tif_config.h"
      |          ^~~~~~~~~~~~~~
compilation terminated.
make[1]: *** [Makefile:273: tifftcl.o] Error 1
make[1]: Leaving directory '/home/mro/Downloads/Img-1.4.11/libtiff'
make: *** [Makefile:99: all] Error 2

---

From: "alice" <[email-masked]>
Date: Thu, 30 Mar 2023 11:03:38 +0200

>   511 |                            uint32 *, uint32 *, uint32 *);

uint32 is not a standard type name, either find what defines it in what you are
building or use uint32_t from <stdint.h>

---

From: [email-masked]
Date: Thu, 30 Mar 2023 11:17:50 +0200

Thanks for your help, after adding

#include <stdint.h>
#define int32 int32_t
#define uint32 uint32_t

in ./libtiff/tifftcl.h

the missing include remains, so I guess I'll give up for now:

$ make
...
In file included from 
/home/mro/Downloads/Img-1.4.11/libtiff/./tifftclDecls.h:38,
                  from 
/home/mro/Downloads/Img-1.4.11/libtiff/./tifftcl.h:53,
                  from tiff.c:22:
/home/mro/Downloads/Img-1.4.11/libtiff/./../compat/libtiff/libtiff/tiffiop.h:33:10: 
fatal error: tif_config.h: No such file or directory
    33 | #include "tif_config.h"
       |          ^~~~~~~~~~~~~~
compilation terminated.
make[1]: *** [Makefile:308: tiff.o] Error 1
make[1]: Leaving directory '/home/mro/Downloads/Img-1.4.11/tiff'
make: *** [Makefile:99: all] Error 2

---

From: David Demelier <[email-masked]>
Date: Thu, 30 Mar 2023 11:23:09 +0200

On Thu, 2023-03-30 at 11:17 +0200, [email-masked] wrote:
> /home/mro/Downloads/Img-
> 1.4.11/libtiff/./../compat/libtiff/libtiff/tiffiop.h:33:10: 

I think the software uses tiff <=3.x because tif_config.h has been
removed from tiff since 4.x.

-- 
David

---

From: [email-masked]
Date: Thu, 30 Mar 2023 15:03:42 +0200

Thanks David,

> removed from tiff since 4.x.

that makes sense, I just reported upstream 
https://sourceforge.net/p/tkimg/mailman/message/37797660/.

Marcus

---

From: donoban <[email-masked]>
Date: Thu, 30 Mar 2023 15:44:53 +0000

> https://pkgs.alpinelinux.org/packages?name=tcllib?

Hi, did you check if it is just included in 'tcl' package?
There are some "/usr/lib/.-." files inside it.

---
Donoban

---

From: donoban <[email-masked]>
Date: Thu, 30 Mar 2023 15:50:59 +0000

> There are some "/usr/lib/.-." files inside it.

Woops, sorry I had not seen the another replies -_-