Subject: [alpine-user] Multiple initramfs appears not to work

From: Andrew Stuart <[email-masked]>
Date: Wed, 3 Jan 2018 06:33:42 +1100

Hi folks,

I want to pass multiple initramfs file to Alpine on boot.

The architecture document says it supports such behaviour:
https://wiki.alpinelinux.org/wiki/Architecture
"The kernel will decompress the stream of compressed cpio archives passed to it by the 'append' bootloader option to the root of 'rootfs', a tmpfs automatically mounted at '/' by the kernel at boot."

As far as I can tell, Alpine appears to ignore all except the first initramfs.

I’ve searching the web extensively to find any syslinux.cfg example that does this for Alpine Linux but can find none, so I’m wondering if it has ever been tested or known to work.

I’ve tried a variety of different ways of specifying in syslinux.cfg but none of them seem to work. Here is an example of one such config.

SERIAL 0 115200
TIMEOUT 20
PROMPT 1
DEFAULT virthardened

LABEL virthardened
MENU LABEL Linux virthardened
KERNEL /boot/vmlinuz-virthardened
INITRD /boot/initramfs-virthardened,/boot/rootfs_overlay_initramfs.gz
DEVICETREEDIR /boot/dtbs
APPEND modules=loop,squashfs,sd-mod,usb-storage quiet console=tty0 console=ttyS0,115200

Is anyone able to help me get Alpine to load more than one initramfs?

thanks

Andrew

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: William Pitcock <[email-masked]>
Date: Sun, 7 Jan 2018 13:24:56 -0600

Hi,

> https://wiki.alpinelinux.org/wiki/Architecture

Unfortunately that page needs to be deleted, because it's basically
fantasy land.

> As far as I can tell, Alpine appears to ignore all except the first initramfs.

That is because the bootloader and kernel do not really work this way.
I spent several months trying to explain this to the author of that
Wiki page.

> Is anyone able to help me get Alpine to load more than one initramfs?

It is not really possible, sorry.

William

---

---

From: Andrew Stuart <[email-masked]>
Date: Mon, 8 Jan 2018 07:26:29 +1100

>>>>That is because the bootloader and kernel do not really work this way.

Perhaps you can help me understand…..  what code exactly is it that Alpine would require/does not have to support this functionality (that other distros such as Ubuntu & Tiny Core have)?  I’ve read quite a bit of stuff but can’t quite put the finger on how Alpine is different in this regard to for example Ubuntu and Tiny Core Linux and I presume other Linux distros? I had thought that using syslinux to boot would be sufficient.

>>>>It is not really possible, sorry.
OK I can stop trying to find the incantation - that will save me alot of time anyway :-)

thanks

Andrew

---

---

From: Andrew Stuart <[email-masked]>
Date: Sun, 21 Jan 2018 21:39:54 +1100

Bumping this - I’d be interested to understand why Alpine isn’t able to handle multiple initramfs

thanks

Andrew

---