Subject: Re: where can i find main repo packages list

From: vishnu vardhan <[email-masked]>
Date: Sun, 28 Feb 2021 00:57:49 -0800

On Sunday, 28 February 2021, 陈杨文 <[email-masked]> wrote:
> you mean https://gitlab.alpinelinux.org/alpine/aports ?

no, i am talking about
stable release - main, community, testing

i am talking about main in stable repository.

---

From: David Davies <[email-masked]>
Date: Sun, 28 Feb 2021 09:01:26 +0000

Is this what you need?
https://mirrors.alpinelinux.org/mirrors.txt

-------- Original message --------
From: vishnu vardhan <[email-masked]>
Date: 28/2/21 19:58 (GMT+10:00)
To: 陈杨文 <[email-masked]>
Cc: ~alpine/[email-masked]
Subject: Re: where can i find main repo packages list

no, i am talking about

David Davies

National: 1300 854 292
www.cybersecure.com<http://www.cybersecure.com>

Australia's trusted cyber protection provider since 2003

---

From: David Davies <[email-masked]>
Date: Sun, 28 Feb 2021 09:05:53 +0000

Sorry, that was incomplete. From that you can get all the packages. For example, I like arrnet mirrors, so I can see all the latest stable main pacakeges for x86_64 at this link:

http://mirror.aarnet.edu.au/pub/alpine/latest-stable/main/x86_64/

-------- Original message --------
From: David Davies <[email-masked]>
Date: 28/2/21 20:02 (GMT+10:00)
To: vishnu vardhan <[email-masked]>, 陈杨文 <[email-masked]>
Cc: ~alpine/[email-masked]
Subject: RE: where can i find main repo packages list

Is this what you need?

-------- Original message --------
From: vishnu vardhan <[email-masked]>
Date: 28/2/21 19:58 (GMT+10:00)
To: 陈杨文 <[email-masked]>
Cc: ~alpine/[email-masked]
Subject: Re: where can i find main repo packages list

no, i am talking about

David Davies

National: 1300 854 292

David Davies

National: 1300 854 292

---

From: vishnu vardhan <[email-masked]>
Date: Sun, 28 Feb 2021 01:32:33 -0800

On Sunday, 28 February 2021, David Davies <[email-masked]>
wrote:
> Sorry, that was incomplete. From that you can get all the packages. For
example, I like arrnet mirrors, so I can see all the latest stable main
> http://mirror.aarnet.edu.au/pub/alpine/latest-stable/main/x86_64/

sorry, i too jumped quickly.
your hyperlink is absolutely useful.

---

From: "Winston Weinert" <[email-masked]>
Date: Sun, 28 Feb 2021 12:06:10 -0600

A supplemental resource - https://repology.org/ .  It had a web API https://repology.org/api .  Maybe this could be used to assess many distros at once.

-- 
  Winston Weinert
  [email-masked]
  https://winny.tech/

On Sun, Feb 28, 2021, at 03:32, vishnu vardhan wrote:
> On Sunday, 28 February 2021, David Davies <[email-masked]> wrote:

---

From: v v <[email-masked]>
Date: Sun, 28 Feb 2021 21:12:52 -0800

On Sunday, 28 February 2021, Winston Weinert <[email-masked]> wrote:
> A supplemental resource - https://repology.org/ .  It had a web API
https://repology.org/api .  Maybe this could be used to assess many distros
at once.

it is promising. certainly saves time to search two or more distros at
once.

---

From: vishnu vardhan <[email-masked]>
Date: Sun, 28 Feb 2021 01:14:10 -0800

> https://mirrors.alpinelinux.org/mirrors.txt

please note that i havent installed os. i am deciding which os to install.

i have to check each and every time my desired package whether it is
available in main repository on package search page(1).

i am searching for some kind of short cut :)

(1)https://pkgs.alpinelinux.org/packages