Subject: [alpine-user] less and Color

From: Andrew Bell <[email-masked]>
Date: Thu, 7 Feb 2019 12:21:54 -0500

Hi,

git diff on alpine seems to pass its output through less, but the color
escape codes seem to get modified/trashed in the process.  I know I can use
git diff --no-color, which works fine, but I'd like to fix or at least
understand why my terminal isn't getting proper escape codes for colors and
instead I get a bunch of '[[31m", for instance.

Ideas appreciated,

-- 
Andrew Bell
[email-masked]

---

From: Cosmo Borsky <[email-masked]>
Date: Thu, 7 Feb 2019 12:28:01 -0500

I use the following in my `~/.profile`
`export LESS="--RAW-CONTROL-CHARS"`

On 2/7/19 12:21 PM, Andrew Bell wrote:
> Hi,
>
> git diff on alpine seems to pass its output through less, but the
> color escape codes seem to get modified/trashed in the process.  I
> know I can use git diff --no-color, which works fine, but I'd like to
> fix or at least understand why my terminal isn't getting proper escape
> codes for colors and instead I get a bunch of '[[31m", for instance.
>
> Ideas appreciated,
>
> -- 
> Andrew Bell
> [email-masked] <mailto:[email-masked]>

---

From: Andrew Bell <[email-masked]>
Date: Thu, 7 Feb 2019 12:44:21 -0500

Hmm,

less on my system has no such option:

$ less
less: missing filename
BusyBox v1.28.4 (2018-12-31 18:05:13 UTC) multi-call binary.

Usage: less [-EIMmNSh~] [FILE]...

View FILE (or stdin) one screenful at a time

-E Quit once the end of a file is reached
-I Ignore case in all searches
-M,-m Display status line with line numbers
and percentage through the file
-N Prefix line number to each line
-S Truncate long lines
-~ Suppress ~s displayed past EOF

-- 
Andrew Bell
[email-masked]

---

From: PICCORO McKAY Lenz <[email-masked]>
Date: Thu, 7 Feb 2019 13:47:53 -0400

maybe you are using the build in less command in busybox.. try install
coreutils related packages

Lenz McKAY Gerardo (PICCORO)
http://qgqlochekone.blogspot.com

El jue., 7 de feb. de 2019 a la(s) 13:44, Andrew Bell
([email-masked]) escribió:
>> git diff on alpine seems to pass its output through less, but the color escape codes seem to get modified/trashed in the process.  I know I can use git diff --no-color, which works fine, but I'd like to fix or at least understand why my terminal isn't getting proper escape codes for colors and instead I get a bunch of '[[31m", for instance.
>>
>> Ideas appreciated,
>>
>> --
>> Andrew Bell
>> [email-masked]
>>
>>
>
>
> --
> Andrew Bell
> [email-masked]

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---