Subject: WSL (Windows) Alpine vs Debian Benchmarks -- 340% better scheduler perf

From: Anthony Metzidis <[email-masked]>
Date: Mon, 6 Apr 2026 12:49:35 -0700

While debugging kernel mitigations (mitigations=off kernel param) in
WSL I noticed that Alpine performance for linux scheduler (perf bench
sched pipe ) is 340% better  on the benchmark (141k ops/sec Alpine vs
41k Debian).

Any theories about the variation ? I've tested on a few separate WSL
alpine installs to make sure it's not a fluke.  It increased with the
latest WSL kernel

# uname -v -r
6.6.114.1-microsoft-standard-WSL2 #1 SMP PREEMPT_DYNAMIC Mon Dec  1
20:46:23 UTC 2025

# Alpine 2.6.3     141383 ops/sec
❯ perf bench sched pipe -l 100000
    Total time: 0.707 [sec]

       7.072980 usecs/op
         141383 ops/sec

# Debian 13.4 41145 ops/sec
❯ perf bench sched pipe -l 100000
# Running 'sched/pipe' benchmark:
# Executed 100000 pipe operations between two processes

     Total time: 2.430 [sec]

      24.303820 usecs/op
          41145 ops/sec

---

From: Stuart Longland VK4MSL <[email-masked]>
Date: Tue, 7 Apr 2026 06:04:58 +1000

> # Alpine 2.6.3     141383 ops/sec

Aren't we up to 2.23.something now?
-- 
Stuart Longland (aka Redhatter, VK4MSL)

I haven't lost my mind...
   ...it's backed up on a tape somewhere.