Subject: alpinelinux 3.11How to run script on startup

From: Eduardo Gonçalves <[email-masked]>
Date: Mon, 2 Mar 2020 11:30:22 -0400

Hi,
I need help on add a script to run on startup on alpinelinux 3.11.

I've added my script to /etc/local.d/myscript.start and enable: rc-update
add local default

but it is not running on system startup.

--
*Eduardo Gonçalves*

---

From: Konstantin Kulikov <[email-masked]>
Date: Mon, 2 Mar 2020 20:18:52 +0300

On 3/2/20 6:30 PM, Eduardo Gonçalves wrote:
> I've added my script to /etc/local.d/myscript.start and 
> enable: rc-update add local default
> 

Did you mark your script as executable (chmod +x 
/etc/local.d/myscript.start)?

---

From: Eduardo Gonçalves <[email-masked]>
Date: Mon, 2 Mar 2020 13:28:55 -0400

Hello,
In fact it’s running but it’s not echoing msgs in startup as it used to
echo in version alpine:3.8