Subject: X11 QEMU/KVM screen resolution

From: Wim Langers <[email-masked]>
Date: Wed, 4 Sep 2019 16:02:00 +0200

My maximum screen resolution in the (Alpine Linux) VM is stuck at 1024x768 ?

After having "googled" and finding myself chasing my own t(r)ail, have come
here for advice.

phase 1 :
- installed Alpine Linux v3.9 on Lenovo Carbon X1 (rev 5) and  X11, DWM,
KVM,...
- installed Alpine Linux v3.9 in a VM and X11, DWM, KVM,...
- installed Windows 10
=> everything worked fine (remote-viewer)

phase 2 :
- update/upgrade Alpine Linux v3.9 on host and guest
=> screen resolution on Alpine Linux VM limited to 1024x768, Windows 10 fine

experiments, experiments, experiments (several weeks of...)
- also upgraded everything to Alpine Linux 3.10, also tried edge, nothing
helps
- also tried installing another linux distro (in a VM), same problem

What stomps me is that Windows 10 VM is working fine (except for the one
time I installed the "latest and greatest" spice-guest-tools => also 1024 x
768)

Any help/pointers appreciated

Wim

---

From: Cosmo Borsky <[email-masked]>
Date: Wed, 04 Sep 2019 14:27:01 +0000

What kind of virtualization are you using? Qemu? VMware?
Check the video driver you are passing into the Alpine instance.
For example, I use `qxl` often with qemu.

---

From: Wim Langers <[email-masked]>
Date: Wed, 4 Sep 2019 21:54:11 +0200

I'm using KVM with Spice and QXL.  And it did work fine until I upgraded
Alpine (no other packages installed or anything changed otherwise)

Wim

On Wed, Sep 4, 2019 at 4:27 PM Cosmo Borsky <[email-masked]> wrote:

>> After having "googled" and finding myself chasing my own t(r)ail, have
>> come here for advice.
>>
>> phase 1 :

---

From: Wim Langers <[email-masked]>
Date: Wed, 9 Oct 2019 07:54:32 +0200

Found the solution

try : replace (in the qemu command to fire up the vm) -vga qxl by -device
qxl-vga,max_outputs=1
close your eyes, click your heels 3 times and whisper "I  want to go home"

Wim

On Wed, Sep 4, 2019 at 9:54 PM Wim Langers <[email-masked]> wrote:

>>> - also upgraded everything to Alpine Linux 3.10, also tried edge,
>>> nothing helps