Subject: [alpine-user] how to package with debootstrap or somethig similar? wiki does not are updated

From: PICCORO McKAY Lenz <[email-masked]>
Date: Mon, 3 Jun 2019 20:56:58 -0400

clear enought:

how to package with debootstrap or somethig similar? wiki does not are
updated!

i made packages very well but using my current daily system.. i want to use
a chroot deboostrap system like debian does?

how to do that?

Lenz McKAY Gerardo (PICCORO)
http://qgqlochekone.blogspot.com

---

From: Marco Dickert <[email-masked]>
Date: Tue, 4 Jun 2019 10:05:50 +0200

> how to package with debootstrap or somethig similar? wiki does not are

I use lxc containers for package building. AFAIK the official alpine
repositories are also created using LXC containers.

> i made packages very well but using my current daily system.. i want to use a
> chroot deboostrap system like debian does?

Of course you can use a chroot environment, too. Check this wiki article [1].

[1] https://wiki.alpinelinux.org/wiki/Installing_Alpine_Linux_in_a_chroot

-- 
Marco Dickert
[email-masked]
https://misterunknown.de

---

From: PICCORO McKAY Lenz <[email-masked]>
Date: Tue, 4 Jun 2019 11:37:31 -0400

> repositories are also created using LXC containers.

HOW?  whre's its the receipt? thanks in advance!

> [1] https://wiki.alpinelinux.org/wiki/Installing_Alpine_Linux_in_a_chroot

after finish to made every package the chrot its contamined.. we need a
debootstrap clean environment and automatized way?

also wiki are several out of date (as always)

---

From: Marco Dickert <[email-masked]>
Date: Wed, 5 Jun 2019 12:07:51 +0200

> HOW?  whre's its the receipt? thanks in advance!

There is no step-by-step tutorial. You can use these [1] instructions to set up
an alpine container and this [2] page to create the build environment.

[1] https://wiki.alpinelinux.org/wiki/LXC
[2] https://wiki.alpinelinux.org/wiki/Creating_an_Alpine_package#Setup_your_system_and_account

> debootstrap clean environment and automatized way?

Hm, I don't really know what you mean, since abuild purges all depencencies it
installed after building the package.

However, if you use LVM-based LXC containers, you can use LVM snapshots to keep
the environment clean.

> also wiki are several out of date (as always)

Feel free to improve the wiki yourself.

Cheers,
-- 
Marco Dickert
[email-masked]
https://misterunknown.de

---

From: PICCORO McKAY Lenz <[email-masked]>
Date: Wed, 5 Jun 2019 07:04:47 -0400

> an alpine container and this [2] page to create the build environment.

OK thanks for the response... my intentions was try to find something
similar to debootstrap
so then refine and made omething like open suse build service...
but seems alpine are so far away from automaton tools
and will be a hard task to do...

> [2]
> https://wiki.alpinelinux.org/wiki/Creating_an_Alpine_package#Setup_your_system_and_account
>

---

From: Marco Dickert <[email-masked]>
Date: Wed, 5 Jun 2019 13:55:52 +0200

> and will be a hard task to do...

Well, I don't see the problem. You have apk.static which provides basically what
debootstrap does. It can be easily automated with a bit of scripting.

If that is too much for you, you could even make use of Docker to create your
own build service. It is indeed a bit of work to do, but I don't see how the
alpine toolchain isn't sufficient to do so.

-- 
Marco Dickert
[email-masked]
https://misterunknown.de

---

From: PICCORO McKAY Lenz <[email-masked]>
Date: Wed, 5 Jun 2019 08:46:07 -0400

> own build service. It is indeed a bit of work to do, but I don't see how
maybe a auto docker script.. that's sound better.. puff yeah if a bit of
work..

thanks..

> alpine toolchain isn't sufficient to do so.
currently are not anought but well i'll try to change and provide feedback