Subject: did alpine follows FHS 3.0 or whatever?

From: PICCORO McKAY Lenz <[email-masked]>
Date: Thu, 1 Oct 2020 07:29:05 -0430

did alpine follows FHS 3.0 or whatever?
https://en.wikipedia.org/wiki/Filesystem_Hierarchy_Standard

Lenz McKAY Gerardo (PICCORO)
http://qgqlochekone.blogspot.com

---

From: Natanael Copa <[email-masked]>
Date: Thu, 1 Oct 2020 14:35:33 +0200

On Thu, 1 Oct 2020 07:29:05 -0430

> https://en.wikipedia.org/wiki/Filesystem_Hierarchy_Standard

Hi!

Yes we mostly follow FHS 3.0, but I don't think we do it 100%

-nc

---

From: PICCORO McKAY Lenz <[email-masked]>
Date: Thu, 1 Oct 2020 17:44:57 -0400

so the fusion that systemd proposed as /usr/bin -> /bin and etc etc will be
in the future? /var/run will be /run now?

---

From: Jordan Geoghegan <[email-masked]>
Date: Thu, 1 Oct 2020 15:22:21 -0700

Alpine doesnt use systemd

On 2020-10-01 14:44, PICCORO McKAY Lenz wrote:
> so the fusion that systemd proposed as /usr/bin -> /bin and etc etc 
> will be in the future? /var/run will be /run now?
>
> El jue., 1 de oct. de 2020 a la(s) 08:35, Natanael Copa 
> ([email-masked] <mailto:[email-masked]>) escribió:
>
>     PICCORO McKAY Lenz <[email-masked]
>     <mailto:[email-masked]>> wrote:
>

---

From: Natanael Copa <[email-masked]>
Date: Wed, 14 Oct 2020 08:21:34 +0200

On Thu, 1 Oct 2020 17:44:57 -0400
PICCORO McKAY Lenz <[email-masked]> wrote:

> in the future? 

No. FHS 3.0 has /bin[1] and /usr/bin[2] separate:

[1]: https://refspecs.linuxfoundation.org/FHS_3.0/fhs/ch03s04.html
[2]: https://refspecs.linuxfoundation.org/FHS_3.0/fhs/ch04s04.html

> /var/run will be /run now?

Yes. It already is and has been for a while. /var/run[3] is (should be) a symlink to /run[4].

[3]: https://refspecs.linuxfoundation.org/FHS_3.0/fhs/ch05s13.html
[4]: https://refspecs.linuxfoundation.org/FHS_3.0/fhs/ch03s15.html

-nc