Subject: [alpine-user] How can install software that only supports sysvinit o systemd?

From: PICCORO McKAY Lenz <[email-masked]>
Date: Sun, 6 Jan 2019 22:42:12 -0400

i have coupe of software that only suports systemd or sysvinit..

the documentation about openrc in the wiki are pretty BAD!

consulting with geento users i have now some knowledg of the openrc but
ther's not enought info..

i want to install nxnomcahine that are only couple of binaries and some
source to compile modules (usb, printing etc)

Lenz McKAY Gerardo (PICCORO)
http://qgqlochekone.blogspot.com

---

From: Paul Zillmann <[email-masked]>
Date: Mon, 7 Jan 2019 18:44:42 +0100

Hello Lenz,

can you explain where you are hitting a bumper?
OpenRC should be very similar to SysVinit.

- Paul

Am 07.01.19 um 03:42 schrieb PICCORO McKAY Lenz:
> consulting with geento users i have now some knowledg of the openrc 
> but ther's not enought info..
>
> i want to install nxnomcahine that are only couple of binaries and 
> some source to compile modules (usb, printing etc)
>

---

From: PICCORO McKAY Lenz <[email-masked]>
Date: Mon, 7 Jan 2019 15:10:26 -0400

> can you explain where you are hitting a bumper?

i cited in my last lines "nx nomachine" do you note it?

> OpenRC should be very similar to SysVinit.

well i thinnk to emulated the install like another sysvinit system and then
tune it the files..
but before i do the most logic and reasonable thin: ask!

so i ask and need, information about converting a sysv-rc installation (o
wors a systemd install) on a alpine to a openrc..

and please! the wiki are a crap! if the wiki are not usefully , get down
and use a git wiki based.. i have many experience with that!

why not a wiki lie the alpine page does? just markdown files and static
content generation!

---

From: Paul Zillmann <[email-masked]>
Date: Mon, 7 Jan 2019 23:41:28 +0100

Hello Lenz,

Am 07.01.19 um 20:10 schrieb PICCORO McKAY Lenz:
> El lun., 7 de ene. de 2019 a la(s) 13:45, Paul Zillmann 
> ([email-masked] <mailto:[email-masked]>) escribió:
>

Yes I've noted that - I still doesn't know what your exact question / 
problem is other than "your documentation is sh*t - give me a tutorial 
how I write init scripts"

Don't be rude and please take a moment to read through 
http://www.catb.org/esr/faqs/smart-questions.html

Thanks,

- Paul

---

From: PICCORO McKAY Lenz <[email-masked]>
Date: Mon, 7 Jan 2019 21:42:18 -0400

no no paul...

i not want a tutorial.. I'll write it,

but i need some tips and info abour openrc, geeton have some usefull info .
scripts are like sysvinit..

but i taking about the specific info related to alpine. intall process of
nxmachines spected a debian or suse or redhat or centos... so i dont want
to try a want to get some tips before try.. due are very hard to isntall if
the system crap and i dont have enought memory for virtual machine

El lun., 7 de ene. de 2019 a la(s) 18:41, Paul Zillmann ([email-masked])
escribió:

> problem is other than "your documentation is sh*t - give me a tutorial how
> I write init scripts"
>

---

From: Martin Rusko <[email-masked]>
Date: Tue, 8 Jan 2019 10:00:47 +0100

Ciao Lenz,

this is how it works here:
* you can't command anyone about what they should do, people here owe
nothing to you
* people will help you, if you show steps what have you done and what
didn't work for you
* if you do not cooperate, you will be ignored

What Paul tried to get from you, is to see what have you tried so far
and didn't work for you. To me it looks like you haven't even started
to install nx nomachine. When you start and you face some problem,
come back to tell us what that problem is. Thank you.

Best regards,
Martin

On Tue, Jan 8, 2019 at 2:42 AM PICCORO McKAY Lenz
<[email-masked]> wrote:
> but i need some tips and info abour openrc, geeton have some usefull info . scripts are like sysvinit..
>
> but i taking about the specific info related to alpine. intall process of nxmachines spected a debian or suse or redhat or centos... so i dont want to try a want to get some tips before try.. due are very hard to isntall if the system crap and i dont have enought memory for virtual machine
>
>
> El lun., 7 de ene. de 2019 a la(s) 18:41, Paul Zillmann ([email-masked]) escribió:
>>
>> Hello Lenz,
>>
>> El lun., 7 de ene. de 2019 a la(s) 13:45, Paul Zillmann ([email-masked]) escribió:
>>>
>> Yes I've noted that - I still doesn't know what your exact question / problem is other than "your documentation is sh*t - give me a tutorial how I write init scripts"
>>
>> Don't be rude and please take a moment to read through http://www.catb.org/esr/faqs/smart-questions.html
>>
>> Thanks,
>>
>> - Paul

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: PICCORO McKAY Lenz <[email-masked]>
Date: Tue, 8 Jan 2019 08:33:11 -0400

> * you can't command anyone about what they should do, people here owe
command? so alpine does not have good support? like Debian, Centos?

i'll detailed steps, i cited:

> > i not want a tutorial.. I'll write it, but i need some tips and info
> abour openrc, geeton have some usefull info . scripts are like sysvinit..
>

I started but its hard to see where are installed the files..  i tune up
some sysv-.init scripts but no luck, there's no libc6 problems due i have
already libc6-compat package, usb and printer modules compiles good, in any
inteligent process firts before install or do something people or
techinician must know the field of work, and later get try right?

> >
> > but i taking about the specific info related to alpine. intall process
> of nxmachines spected a debian or suse or redhat or centos... so i dont
> want to try a want to get some tips before try.. due are very hard to
> isntall if the system crap and i dont have enought memory for virtual
> machine
> >
> >

---

From: Natanael Copa <[email-masked]>
Date: Thu, 10 Jan 2019 12:28:52 +0100

On Tue, 8 Jan 2019 08:33:11 -0400

> command? so alpine does not have good support? like Debian, Centos?

We don't support sysvinit or systemd nor precompiled applications that
requires libc6, like Debian and Centos does. Sorry.

Maybe you can ask nx nomachine community to help you?
https://www.nomachine.com/support

-nc

---

---

From: PICCORO McKAY Lenz <[email-masked]>
Date: Thu, 10 Jan 2019 08:49:26 -0400

> requires libc6, like Debian and Centos does. Sorry.
Hi Natan, i already know that alpine uses Openrc,
please if you read firts mails understand the context of my topic..
i try to give setup to some tirth-party apps under alpine, currently
there's
no good remote apps on linux agains teamviewer but recently exists anydesk
and nomachine,

so then, i try to give some adaptations to nomachine scripts
but i not found many technical documentations easy to understand about
openrc
ironically geento have more good reception rather that list..

> really? well the tipicall response.. "use XXX OS" we can make the
difference right?

---

From: Jakub Jirutka <[email-masked]>
Date: Tue, 8 Jan 2019 15:06:14 +0100

>> you can't command anyone about what they should do, people here owe
nothing to you
> command? so alpine does not have good support? like Debian, Centos?

What kind of support do you mean? Alpine is basically a community driven
project. If you're looking for a commercial support, you can ask e.g.
me; my price is 50 USD/hour.
If you're looking for a community support for free, you have to change
your attitude.

Jakub

On 1/8/19 1:33 PM, PICCORO McKAY Lenz wrote:
> El mar., 8 de ene. de 2019 a la(s) 05:00, Martin Rusko
> ([email-masked] <mailto:[email-masked]>) escribió:
> 
>     > i not want a tutorial.. I'll write it, but i need some tips and
>     info abour openrc, geeton have some usefull info . scripts are like
>     sysvinit..
> 
> 
> 
> 
> some sysv-.init scripts but no luck, there's no libc6 problems due i
> have already libc6-compat package, usb and printer modules compiles
> good, in any inteligent process firts before install or do something
> people or techinician must know the field of work, and later get try right?
> 
>  
> 
>     >
>     > but i taking about the specific info related to alpine. intall
>     process of nxmachines spected a debian or suse or redhat or
>     centos... so i dont want to try a want to get some tips before try..
>     due are very hard to isntall if the system crap and i dont have
>     enought memory for virtual machine
>     >
>     >
>     > El lun., 7 de ene. de 2019 a la(s) 18:41, Paul Zillmann
>     >> Yes I've noted that - I still doesn't know what your exact
>     question / problem is other than "your documentation is sh*t - give
>     me a tutorial how I write init scripts"
>     >>

---