Subject: ipv6 rtunnel config confirmation help

From: PICCORO McKAY Lenz <[email-masked]>
Date: Wed, 29 Jul 2020 09:00:59 -0430

to make right documentation for the wiki (that was lack of good information
in old days for starter users) i get involved in ipv6 world

now i try to configure dualstack and tunnel broker, but in the list only i
have: Debian, winbuntu, linux-nettools and linux-iproute2 ..

based on alpine OS structure i try to coparre eacho one and i want to
confirm if the right choose is the "Linux-route2" cos use same commands and
modules i found in alpine linux:

```
modprobe ipv6
ip tunnel add he-ipv6 mode sit remote X.X.X.X local Y.Y.Y.Y ttl 255
ip link set he-ipv6 up
ip addr add X:XXX:XXX:XXX::2/64 dev he-ipv6
ip route add ::/0 dev he-ipv6
ip -f inet6 addr
```

BUT the option of Debian also seems could be compatible:

```
auto he-ipv6
iface he-ipv6 inet6 v4tunnel
        address X:XXX:XXX:XXX::2
        netmask 64
        endpoint X.X.X.X
        local Y.Y.Y.Y
        ttl 255
        gateway X:XXX:XXX:XXX::1
```

where endpoint is X.X.X.X
public ip Y.Y.Y.Y
public ip6 X:XXX:XXX:XXX::2

so wicht configuration must I use for an alpine tunnel broker?

Lenz McKAY Gerardo (PICCORO)
http://qgqlochekone.blogspot.com

---

From: Paul Zillmann <[email-masked]>
Date: Tue, 4 Aug 2020 22:11:35 +0200

Hey Piccoro,

Am 29.07.20 um 15:30 schrieb PICCORO McKAY Lenz:
> to make right documentation for the wiki (that was lack of good 
> information in old days for starter users) i get involved in ipv6 world
>
> now i try to configure dualstack and tunnel broker, but in the list 
> only i have: Debian, winbuntu, linux-nettools and linux-iproute2 ..
>
> confirm if the right choose is the "Linux-route2" cos use same 
> commands and modules i found in alpine linux:
>

It depends on how you would like to work with your network stack. You 
usually use iproute2 for the CLI and /etc/network/interfaces (the so 
called Debian way) for automated configuration.

Both work, both can be used in parallel, both are interchangeable with 
each other.
It depends on what you like and what you need.

Unfortunately I only have experience with dual stack configuration. I 
have never worked with a tunnel broker.

P.S.: with iproute2 I would rather use "ip -6 route add default via..."

- Paul

---

From: PICCORO McKAY Lenz <[email-masked]>
Date: Tue, 4 Aug 2020 16:17:21 -0400

El mar., 4 de ago. de 2020 a la(s) 16:08, Paul Zillmann ([email-masked])
escribió:

> usually use iproute2 for the CLI and /etc/network/interfaces (the so called
> Debian way) for automated configuration.
>
> Unfortunately I only have experience with dual stack configuration. I have
> never worked with a tunnel broker.
>

THAT WAS PRETTY CLEAR.. now i noted i need more study on ipv6 to make and
understand future answers.. thanks a lot.. i ned to prepare more! so by
now.. i cannot make any network related wiki page yet!

---

From: Bjoern Franke <[email-masked]>
Date: Sat, 13 Mar 2021 21:56:33 +0100

Hi,

> 
> THAT WAS PRETTY CLEAR.. now i noted i need more study on ipv6 to make
> and understand future answers.. thanks a lot.. i ned to prepare more! so
> by now.. i cannot make any network related wiki page yet!

Did it work for you?

I tried to get a tunnel up via interfaces:

auto netassist
iface netassist inet6 v4tunnel
	address 2a01:d0:ffff:1408::xy
        netmask 64
	endpoint 62.205.132.12
	local 45.14.150.yx

But just nothing happens when running "ifup netassist".

Creating the tunnel manually via iproute2-commands works fine.

Kind Regards
Bjoern