Subject: [alpine-user] Gnumeric bug

From: Deniz Berkay <[email-masked]>
Date: Sun, 14 Jan 2018 19:28:09 -0200

I'm on a clean alpine environment.
Installed gnumeric.
It doesn't launch.

Issue:
- $ gnumeric
process 4841: D-Bus library appears to be incorrectly set up; failed
to read machine uuid: Failed to open "/etc/machine-id": No such file
or directory
See the manual page for dbus-uuidgen to correct this issue.
D-Bus not compiled with backtrace support so unable to print a backtrace
Aborted

Another caveat:
- I got in my system 2 binaries: /usr/bin/gnumeric +
/usr/bin/gnumeric-1.12.37
diff tells me they are exactly the same.
Why have both?

Cheers.

---

From: Deniz Berkay <[email-masked]>
Date: Sun, 14 Jan 2018 19:30:05 -0200

I found a fix.

echo "00000000000000000000000000000000" > /etc/machine-id
(needs this exact number of zeros)

This command must be added in the Gnumeric package as default.

---

From: Cág <[email-masked]>
Date: Tue, 16 Jan 2018 20:27:12 +0000

> This command must be added in the Gnumeric package as default.

Does it work without it? I always have a bunch of dbus related errors in some
GTK programmes because dbus is not running.

> /usr/bin/gnumeric-1.12.37

gnumeric is a symlink to gnumeric-1.12.37, similar to gimp being a symlink to
gimp-2.8.

-- 
caóc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Deniz Berkay <[email-masked]>
Date: Tue, 16 Jan 2018 21:19:17 -0200

> GTK programmes because dbus is not running.

It doesn't work. Doesn't even open; just quit.
I don't have dbus installed or running and I don't want it.

> gnumeric is a symlink to gnumeric-1.12.37, similar to gimp being a
symlink to

But what is that for?
Does it help with something I don't understand?

---

From: Cág <[email-masked]>
Date: Thu, 18 Jan 2018 09:51:57 +0000

> I don't have dbus installed or running and I don't want it.

The same version works for me. Do you use edge?

>> gnumeric is a symlink to gnumeric-1.12.37, similar to gimp being a
>> symlink to gimp-2.8.
> But what is that for?

It is the default behaviour. You should rather ask the devs.

Cheers
-- 
caóc

---

---

From: Deniz Berkay <[email-masked]>
Date: Sat, 27 Jan 2018 15:35:47 -0200

>The same version works for me. Do you use edge?

Yes, I use edge.