Subject: [alpine-user] Mongo DB Tools

From: Gabor Toth <[email-masked]>
Date: Sun, 8 Apr 2018 09:40:57 +0200

Dear All,

I am building a Docker Image from  node:8-Alpine, and I am trying to add
not only mongodb but also mongodb-tools (mongorestore, mongodump etc
commands), and apk add mongodb-tools is not working:

libsasl2-dev (missing):
    required by: world[libsasl2-dev]

but I have added libsasl2-dev earlier:

RUN apk update && apk upgrade && \
    apk add \
      bash \
      g++ \
      gcc \
      make \
      boost-system \
      boost \
      mongodb \
      go \
      libsasl2-dev \
      libpcap \
      libpcap-dev \
      mongodb-tools \
      --no-cache && \
    rm -rf /var/cache/apk/*

Can you please let me know how to install mongodb-tools?

Thanks,

Gabor

---

From: Cág <[email-masked]>
Date: Sun, 8 Apr 2018 08:58:15 +0000

Gabor Toth wrote:

> I am building a Docker Image from  node:8-Alpine, and I am trying to
> add not only mongodb but also mongodb-tools (mongorestore, mongodump
> etc commands), and apk add mongodb-tools is not working:

Hi,

libsasl2-dev is a non-existent package. "apk add mongodb-tools" works
in edge. Which version are you using? In 3.7 the dependencies are:
libpcap, libressl2.6-libcrypto, libress2.6-libssl, libsasl, musl.
In edge: libpcap, libsasl, musl. cyrus-sasl-dev is needed to build it.

Cheers

--
caóc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Gabor Toth <[email-masked]>
Date: Mon, 9 Apr 2018 08:25:14 +0200

Hi,

Many thanks for the answer. cat /etc/apk/repositories output after building
the container

http://dl-cdn.alpinelinux.org/alpine/v3.6/main

http://dl-cdn.alpinelinux.org/alpine/v3.6/community

http://dl-2.alpinelinux.org/alpine/edge/community/

After this I tried this in the container but did not work:

sudo apk add --update --repository http://dl-cdn.alpinelinux.org/
alpine/v3.7/community mongodb-tools

I am wondering how I can add the edge repo when building the docker
container? Are dependencies automatically added or should I apk update them
myself?

Thanks,

Gabor