Subject: [alpine-user] Raspberry pi 3 install via ssh

From: Bryan Honof <[email-masked]>
Date: Tue, 17 Jul 2018 00:07:50 +0200

Hey I was just wondering if it's possible to install alpine onto a
raspberry pi but by enabling ssh on the first boot?

Thanks in advance!

---

From: Herry Herry <[email-masked]>
Date: Thu, 19 Jul 2018 21:17:47 +0100

Hi Bryan

I think you can use Alpine local backup (https://wiki.alpinelinux.org/wiki/Alpine_local_backup <https://wiki.alpinelinux.org/wiki/Alpine_local_backup>) to save your setup to persistent storage and reload it again when booting up.

To enable ssh server, you can do the following steps:

	apk add openssh-server
	rc-update add sshd default
	adduser bryan
	lbu commit

Next time you reboot your system, the ssh server will be automatically started and then you can login to your Pi.

Herry

> On 16 Jul 2018, at 23:07, Bryan Honof <[email-masked]> wrote:
> 
> Hey I was just wondering if it's possible to install alpine onto a raspberry pi but by enabling ssh on the first boot?
> 
> Thanks in advance!

---
PGP key: FC28 2A0A BC36 27FE DF2C  A4FA A538 76B2 04C9 A359