Subject: Raspbery Pi lbu issue

From: "alex wennerberg" <[email-masked]>
Date: Sat, 29 May 2021 23:39:49 -0700

Hey all,

I enjoy using Alpine on Raspberry Pis, but I have encountered this issue before and I wanted to report it. 
I use an in-memory install (to reduce SD card wear) on a Pi Zero. Sometimes this leads to a "no space left on device" error.
At this point, I need to run lbu commit. However, lbu doesn't seem to function in this state, and breaks.
I then restart my Pi, and sometimes, the Pi is completely bricked, doesn't boot at all. Not sure if this is 
enough information for you all, if you need, I can try and reproduce the issue and note the logs, etc.

All the best,
Alex

---

From: Marvin Preuss <[email-masked]>
Date: Tue, 1 Jun 2021 08:34:39 +0200

Hi,

> enough information for you all, if you need, I can try and reproduce the issue and note the logs, etc.

two things I would consider:

1. Checking the SD card. I had similar problems with lbu when the SD
card was dull.

2. I had the problem ones when the memory was full and i got the "no
space left on device" on a diskless installation. But this didnt happend
for a long time.