Subject: VPS providers with Alpine

From: Bosco Vallejo-Nágera <[email-masked]>
Date: Sun, 01 May 2022 11:10:27 +0200

Hello, I've been on the lookout for VPS providers with Alpine linux as
an option (I know some offer bring your own ISO)
I thought it would be a good idea to keep this thread dedicated to
listing these providers.
I'll start with the one I'm currently using
virtua (dot) cloud

---

From: Isak Holmström <[email-masked]>
Date: Sun, 01 May 2022 11:17:47 +0200

______
  -ISAK

> I'll start with the one I'm currently using
vultr.com

---

From: Wolf <[email-masked]>
Date: Sun, 1 May 2022 13:27:00 +0200

> > I'll start with the one I'm currently using

https://vpsfree.cz/

-- 
There are only two hard things in Computer Science:
cache invalidation, naming things and off-by-one errors.

---

From: "Xe Iaso" <[email-masked]>
Date: Sun, 01 May 2022 17:37:45 +0000

> I'll start with the one I'm currently using

I've had good luck with installing Alpine on Vultr via the bring your
own ISO setup. The Alpine virt ISO works perfectly on Vultr. I used to
run a few servers like that.

Xe Iaso (zi ai-uh-so)
https://christine.website

.i la budza pu cusku lu
 <<.i ko snura .i ko kanro
   .i ko panpi .i ko gleki

---

From: Andreas Heil <[email-masked]>
Date: Sun, 1 May 2022 20:18:28 +0200

Hello,

Hetzner’s cloud works good, too.
They’ve Alpine in their "ISO-Store“.

https://www.hetzner.com

Sidenote:
When not using DHCP, you have to configure (IPv4-)network like this:
(e.g. /etc/network/interfaces)

auto eth0
iface eth0 inet static
	address a.b.c.d
	netmask 255.255.255.255
	gateway 172.31.1.1
	pointopoint 172.31.1.1

Best Regards,
Andreas

> Am 01.05.2022 um 11:10 schrieb Bosco Vallejo-Nágera <[email-masked]>:
>

---

From: Bjoern Franke <[email-masked]>
Date: Sun, 1 May 2022 20:20:22 +0200

> I'll start with the one I'm currently using

alphavps.com provides netboot.xyz where booting Alpine works just fine.

Regards

---

From: Jes Olson <[email-masked]>
Date: Wed, 4 May 2022 03:20:36 -0500

https://capsul.org has alpine 3.15 available!

disclosure: i help maintain capsul :3

---

From: Bosco Vallejo-Nágera <[email-masked]>
Date: Wed, 04 May 2022 08:45:36 +0200

So far we have

Directly deploy alpine:
-virtua.cloud
-vpsfree.cz
-hetzner.com
-capsul.org

Upload your own ISO
-vultr.com
-alphavps.com

Would be interesting to see which ones support the diskless and data
disk modes

---

From: Konstantin Kulikov <[email-masked]>
Date: Wed, 4 May 2022 11:25:33 +0300

scaleway.com doesn't provide ready to use images, but you can install manually.

Switch server to rescue mode - this enables ipxe firmware, so you can
press ctrl+b during boot, then type
dhcp
chain https://boot.alpinelinux.org/boot.ipxe
then select flavor=virt console=ttyS0 in the menu and install as usual.

---

From: Andreas Heil <[email-masked]>
Date: Wed, 4 May 2022 10:30:07 +0200

Well,

With Hetzner.com it would be like this:

If you create a server you have to choose between Ubuntu, Fedora, Debian, CentOS and Rocky Linux.

After that you can choose „Alpine Virtual 3.15“ in the ISO-Images section of the server and install or use as usual.
So it should work without using sys mode. But I did not test that so far.

Best Regards,
Andreas

> Am 04.05.2022 um 08:45 schrieb Bosco Vallejo-Nágera <[email-masked]>:
> 
> So far we have
> 
> Directly deploy alpine:
> -virtua.cloud
> -vpsfree.cz
> -hetzner.com
> -capsul.org
> 
> Upload your own ISO
> -vultr.com
> -alphavps.com
>