Subject: NetworkManager stopped working

From: Bosco Vallejo-Nágera <[email-masked]>
Date: Tue, 19 Jul 2022 22:31:00 +0200

I've been using NetworkManager with wpa_supplicant as a backend and it
worked just fine, until for some reason it didn't.

This is my /etc/NetworkManager/NetworkManager.conf
[main]
dhcp=internal
plugins=ifupdown, keyfile
[ifupdown]
managed=true
[device]
wifi.scan-rand-mac-address=yes
wifi.backend=wpa_supplicant

And this is my /etc/network/interfaces
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto wlan0
iface wlan0 inet dhcp

I've tried switching to just wpa_supplicant and it worked, so my wifi
card is working, and it isn't off in rfkill.

However, when I go to nmtui and enter "Activate a connection" and I
don't see wifi there, only ehternet.

My user is in the plugdev group, but if I go to "Set system hostname", I
get the error message "Unable to set hostname: Insufficient privileges"
Anywhere else I should look?

---

From: Bosco Vallejo-Nágera <[email-masked]>
Date: Fri, 23 Dec 2022 22:04:53 +0100

I forgot about this thread, turns out after an update the networkmanager
package was split and it now required networkmanager-wifi as an extra
package.