Subject: Smokeping Lighttpd config issue

From: Phani Krishna Raavi <[email-masked]>
Date: Mon, 8 Jun 2020 01:09:44 +0530

There is an issue with the Howto Smokeping in Alpine Linux (https://wiki.alpinelinux.org/wiki/Setting_up_Smokeping <https://wiki.alpinelinux.org/wiki/Setting_up_Smokeping>)  the lighttpd config is not working in the cgi. also what is the working URL in the above config.

---

From: PICCORO McKAY Lenz <[email-masked]>
Date: Sun, 7 Jun 2020 22:47:48 -0400

i read that wiki page.. everything on it is the biggest piece of crap I've
ever seen:

1) it uses sudo..
2) set up 777 to a file.. so are worldwide writeable
3) set up soft links that breaks and unorganized the filesystem hierarchy
4) added world wide permission to the lighttpd user

also of course it break all kind of security, puff

CORRECT WAY:

1) DONT USE ANY SUDO SHIT
2) use aliasing in lighttpd.. check lighttpd wiki page for examples
3) use aliasing to the .simg file event setup soft links
4) added lighttpd user to the net group to able to use traceroute, or use
setuid
5) added lighttpd user to the net group to able to use fping, or use setuid

All the monitoring production deploys must be like Catci wiki page:
https://wiki.alpinelinux.org/wiki/Cacti:_traffic_analysis_and_monitoring_network

Lenz McKAY Gerardo (PICCORO)
http://qgqlochekone.blogspot.com

El dom., 7 de jun. de 2020 a la(s) 15:39, Phani Krishna Raavi ([email-masked])
escribió:

> There is an issue with the Howto Smokeping in Alpine Linux (
> https://wiki.alpinelinux.org/wiki/Setting_up_Smokeping)  the lighttpd
> config is not working in the cgi. also what is the working URL in the above
> config.
>

---

From: Phani Krishna Raavi <[email-masked]>
Date: Mon, 8 Jun 2020 11:04:04 +0530

Dear PICCORO McKAY Lenz, 

Is it possible to give the new set/flow of commands and changes in the config files so the WIKI document can also be updated and it will be helpful to a lot of Network Admins who are looking for a lightweight Smokeping solution. 

Regards

Phani Krishna Ravi

> On 08-Jun-2020, at 8:17 AM, PICCORO McKAY Lenz <[email-masked]> wrote:
> 
> i read that wiki page.. everything on it is the biggest piece of crap I've ever seen:
> 
> 1) it uses sudo.. 
> 4) added lighttpd user to the net group to able to use traceroute, or use setuid
> All the monitoring production deploys must be like Catci wiki page: https://wiki.alpinelinux.org/wiki/Cacti:_traffic_analysis_and_monitoring_network <https://wiki.alpinelinux.org/wiki/Cacti:_traffic_analysis_and_monitoring_network>
> 
> 
> http://qgqlochekone.blogspot.com <http://qgqlochekone.blogspot.com/>
> 
> El dom., 7 de jun. de 2020 a la(s) 15:39, Phani Krishna Raavi ([email-masked] <mailto:[email-masked]>) escribió:

---

From: PICCORO McKAY Lenz <[email-masked]>
Date: Tue, 9 Jun 2020 04:53:11 -0400

currently i'm working in docker documentation.. right now exact commands
are just variations of the wiki pages of cacti..

but with one adition.. usage of aliasing is the correct and professional way!

i try to updated that wiki page but curently not right now! please
read about aliasing in lighttp config wiki

2020-06-08 1:34 GMT-04:00, Phani Krishna Raavi <[email-masked]>:
> Dear PICCORO McKAY Lenz,
>
> Is it possible to give the new set/flow of commands and changes in the
> config files so the WIKI document can also be updated and it will be helpful
> to a lot of Network Admins who are looking for a lightweight Smokeping
> solution.
>
> Regards
>
>
> Phani Krishna Ravi
>
>
>
>
>
>
>
>> <https://wiki.alpinelinux.org/wiki/Cacti:_traffic_analysis_and_monitoring_network>
>>
>>
>> El dom., 7 de jun. de 2020 a la(s) 15:39, Phani Krishna Raavi
>> ([email-masked] <mailto:[email-masked]>) escribió:
>> There is an issue with the Howto Smokeping in Alpine Linux
>> (https://wiki.alpinelinux.org/wiki/Setting_up_Smokeping
>> <https://wiki.alpinelinux.org/wiki/Setting_up_Smokeping>)  the lighttpd
>> config is not working in the cgi. also what is the working URL in the
>> above config.
>
>

--

---

From: Al Pi <[email-masked]>
Date: Mon, 8 Jun 2020 23:16:58 +0200 (CEST)

> PICCORO McKAY Lenz <[email-masked]> hat am 8. Juni 2020 um 04:47 geschrieben: 
>
>  
> CORRECT WAY:
>  

Why do you think a sudo rule, that allows a user only a specific command (possibly
only with specific options), would be worse than adding a network facing
daemon to the net group?