Subject: [alpine-user] MELTDOWN + SPECTRE

From: "Piskule, Robert" <[email-masked]>
Date: Thu, 4 Jan 2018 21:47:37 +0000

I wanted to know if Alpine Linux is vulnerable to the recent Meltdown or Spectre attacks. Are there any patches? If running from within Docker, is there anything I need to do?

Thanks,
-Rob

---

From: Jakub Jirutka <[email-masked]>
Date: Fri, 5 Jan 2018 00:25:18 +0100

Hi,

did I understand correctly that you run Alpine only inside a Docker container, not a host system? If so, then there’s nothing Alpine can do against Meltdown or Spectre. The host system (its kernel) must be patched.

Jakub

> On 4. Jan 2018, at 22:47, Piskule, Robert <[email-masked]> wrote:
>

---

From: "Piskule, Robert" <[email-masked]>
Date: Thu, 4 Jan 2018 23:50:11 +0000

Jakub, thanks for getting back to me.

Yes, that is correct. Do you personally work for Alpine? Is this an official answer from Alpine?

Thanks,
-Rob

From: Jakub Jirutka [mailto:[email-masked]]
Sent: Thursday, January 4, 2018 6:25 PM
To: Piskule, Robert <[email-masked]>
Cc: [email-masked]
Subject: Re: [alpine-user] MELTDOWN + SPECTRE

Hi,

did I understand correctly that you run Alpine only inside a Docker container, not a host system? If so, then there's nothing Alpine can do against Meltdown or Spectre. The host system (its kernel) must be patched.

Jakub

On 4. Jan 2018, at 22:47, Piskule, Robert <[email-masked]<mailto:[email-masked]>> wrote:

Thanks,
-Rob

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 5 Jan 2018 01:51:09 +0200

The patch against Meltdown is kernel only. Docker containers run within the kernel of the host system. This means the resistance against Meltdown depends on the host kernel only. In other words: you don't need patches against Meltdown in the docker image and you cannot patch against Meltdown in the docker image.

_________________ eXtremeSHOK.com _________________

> On 05 Jan 2018, at 01:50, Piskule, Robert <[email-masked]> wrote:
>