Subject: [alpine-user] Wifi device not detected after disk-based installation

From: Chris Crayton <[email-masked]>
Date: Thu, 30 Aug 2018 22:13:49 +0000

I am having an issue where Alpine Linux properly detects the wireless interface on my Raspberry Pi 3 B+ just fine for a normal install, but when I use the tutorial from the wiki to make a disk-based install it is not found. I have pulled my hair out trying every page on the Alpine wiki and everything I can find on Google with no results. The module will not load, and I cannot find a clear, unambiguous set of instructions for how to troubleshoot an issue with loading firmware for the Pi. I find things like "if you make a firmware directory Alpine will load that before boot" but of course they do not mention the name of the directory to make.

Can someone point to anything that can help me to get the bloody drivers loaded on a disk-based install?

---

From: "Jean-Louis Fuchs" <[email-masked]>
Date: Tue, 04 Sep 2018 15:57:37 +0200

Hi Chris

An idea:

1. Boot normally: not disk-based
2. Run lsmod and find out which module provides wifi
3. Boot in disk-based mode
4. modprobe the module

If it fails send the error-message.

Another idea:

1. Install all linux-firmare package: apk add linux-firmware

Best,
Jean-Louis

On Fri, 31 Aug 2018, at 00:13, Chris Crayton wrote:
> I am having an issue where Alpine Linux properly detects the wireless
> interface on my Raspberry Pi 3 B+ just fine for a normal install, but
> when I use the tutorial from the wiki to make a disk-based install it
> is not found. I have pulled my hair out trying every page on the
> Alpine wiki and everything I can find on Google with no results. The
> module will not load, and I cannot find a clear, unambiguous set of
> instructions for how to troubleshoot an issue with loading firmware
> for the Pi. I find things like "if you make a firmware directory
> Alpine will load that before boot" but of course they do not mention
> the name of the directory to make.> 
> Can someone point to anything that can help me to get the bloody
> drivers loaded on a disk-based install?>