Subject: Alpine and low end hardware: a good experience

From: [email-masked]
Date: Fri, 6 Feb 2026 15:33:14 +0100 (CET)

Hi, Alpine community, I think this is the first time I've written to a list. 

So, I simply wanted to mention that I have loved Alpine for one simple reason: it is low-end friendly, I have been able to have a very good experience using old hardware. For economic reasons I cannot afford a new PC or upgrade my current one, so, I have learned to survive in this digital era with my limitations (2GB of RAM, Intel core 2duo, etc), things like zram and swap help improve the experience. Well, for a long time I was curious about Alpine but I was intimidated by how difficult it could be to install and configure it, I've only been on Linux for a year so I'm not an expert at installing an entire OS from a terminal haha, but I did it and I don't regret it, I've been here for 2 months and it's already my favorite distro, it's the best experience I've had. 

I don't know what other people's experiences are like but for me: Alpine on a low-end desktop is a very good option n.n

---

From: Naomi Rennie-Waldock <[email-masked]>
Date: Wed, 11 Feb 2026 18:10:08 +0000

>I don't know what other people's experiences are like but for me: Alpine on a low-end desktop is a very good option n.n

Alpine works great on low end hardware. I'm running it on a Chromebook with 2GB RAM, it's actually quite responsive (even with full disk encryption) with 1GB RAM used for swap on zram