Subject: Re: [alpine-user] upgrading to edge

From: Fungi4All <[email-masked]>
Date: Tue, 18 Sep 2018 11:21:05 +0000

> ‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
 > On Tuesday, September 18, 2018 3:08 AM, Wayne [email-masked] wrote:
 >
 > > ahoy all,
 > > successfully installed Alpine 3.8 on an x86-64 machine and then
 > > tried to upgrade to the rolling 'edge' release using these instructions:
 > > https://wiki.alpinelinux.org/wiki/Include:Upgrading_to_Edge
 > > the instructions finish with saying that upon updating to edge the
> > > command 'cat /etc/alpine-release' should show a 'build date attached
 > > to the release'. however after following all instructions and
 > > rebooting 'cat /etc/alpine-release' still gives me '3.8.0'.
 > > is the wiki incorrect or does this indicate that i have not been
 > > upgraded to edge? i would be happy to update the wiki in whatever case.
 > > thanks, w
 >
> > Yeah, its a bug that has been reported by me and a bunch of other people. Still awaiting a fix..... . ;-(

 I started with 3.7 and now that you mentioned it I checked

 cat /etc/alpine-release
 3.8.1

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Tim Jones <[email-masked]>
Date: Tue, 18 Sep 2018 12:12:04 +0000

> I started with 3.7 and now that you mentioned it I checked

I've been finding Alpine's approach to fixing bugs somewhat haphazard and frustrating.

<rant mode>

For example, there was a bad build of Postfix which effectively left Postfix broken and unusable.  They fixed it in edge and promised they would backport to 3.8.

When 3.8.1 was released recently, I checked ... but no... it seems they've decided to defer the Postfix fix to 3.9.

As a result, I have been forced to move my mailserver needs over to another Linux distro that actually has a working Postfix in their repo.

Sure I could build my own Postfix from source, but that misses the point of having a repo, especially with things like Postfix.

</rant mode>

---