Subject: [alpine-user] Screen Resolution Setting

From: "Blanco, Joseph" <[email-masked]>
Date: Fri, 14 Jun 2019 07:12:05 +0000

Hello,

I have a laptop on which I have installed Alpine.  So far, seems like a great OS and has the features I need.  I am not using a GUI just command line.  The laptop screen is a 13" 1K (1920x1080) screen.  Alpine recognizes the native resolution and adjust the display to 1K.   However, at this resolution the text is way too small.  How can I adjust the post boot up resolution to something more useful such as 1280x720?   I have searched the internet and discussion boards but have not been successful in a solution that works.   Thanks for any help you can provide.

Best regards,

Joe Blanco
National Support Specialist
Image Guided Therapy
Philips Healthcare
E-mail [email-masked]<mailto:[email-masked]>

  ________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

---

From: Marco Dickert <[email-masked]>
Date: Fri, 14 Jun 2019 09:57:20 +0200

Hi,

> I have a laptop on which I have installed Alpine.  So far, seems like a great OS and has the features I need.  I am not using a GUI just command line.  The laptop screen is a 13" 1K (1920x1080) scr…

I didn't try this myself, but AFAIK you have to set the framebuffer resolution
in the bootloader. First, check out the supported resolutions using hwinfo:

```
$ apk add hwinfo
$ hwinfo --framebuffer
```

Then you can set the desired resolution in the bootloader. If you use syslinux,
you achieve that by editing the bootloader configuration (/boot/extlinux.conf):

```
MENU RESOLUTION <width> <height>
```

See also this wiki page:
https://wiki.syslinux.org/wiki/index.php?title=Menu#MENU_RESOLUTION

-- 
Marco Dickert
[email-masked]
https://misterunknown.de

---

From: PICCORO McKAY Lenz <[email-masked]>
Date: Fri, 14 Jun 2019 10:26:09 -0400

HEY! there's two behaviour here!

one its made the fonts more bigger at the framebuffer console and other are
made the resolution without space!

1) with max resolution but fonts bigger will consume more because it will
need more RAM for the video buffer and cpu processing, but will be more
controlled
2) with a specific lower resolution (pass MENU RESOLUTION <width> <height>
at extlinux.conf) will run more optimized due less consuption

Lenz McKAY Gerardo (PICCORO)
http://qgqlochekone.blogspot.com

El vie., 14 de jun. de 2019 a la(s) 03:57, Marco Dickert (
[email-masked]) escribió:

> > I have a laptop on which I have installed Alpine.  So far, seems like a
> great OS and has the features I need.  I am not using a GUI just command
> line.  The laptop screen is a 13" 1K (1920x1080) screen.  Alpine recognizes
> the native resolution and adjust the display to 1K.   However, at this
> resolution the text is way too small.  How can I adjust the post boot up
> resolution to something more useful such as 1280x720?   I have searched the
> internet and discussion boards but have not been successful in a solution
> that works.   Thanks for any help you can provide.
>