Subject: Loading Alpine guest as a VM in Bhyve

From: doa379 <[email-masked]>
Date: Sat, 16 Jan 2021 14:55:29 +0000

I'm trying to run Alpine as a guest VM under Bhyve. The Alpine ISO I'm 
using is with the -virt suffix. I've run it under KVM and it loads 
successfully. I'm trying to run it using Bhyve but the boot 
sequence seems to stall during mounting boot media. These 
are last few lines of output to the console:

Alpine Init 3.4.5-r3
 * Loading boot drivers: [   47.770381] loop: module loaded
[   47.781958] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[   47.817714] ACPI: bus type USB registered
[   47.821307] usbcore: registered new interface driver usbfs
[   47.825793] usbcore: registered new interface driver hub
[   47.830224] usbcore: registered new device driver usb
[   47.844285] usbcore: registered new interface driver usb-storage
ok.
 * Mounting boot media: [   47.943875] virtio-pci 0000:00:02.0: virtio_pci: leaving for legacy driver
[   47.950140] virtio-pci 0000:00:04.0: virtio_pci: leaving for legacy driver
[   48.028324] virtio_blk virtio1: [vda] 2097152 512-byte logical blocks (1.07 GB/1.00 GiB)
//...waiting...//

At the Alpine bootstrapper the Linux kernel parameters are these:

linux /boot/vmlinuz-virt modules=loop,squashfs,sd-mod,usb-storage,sr-mod console=tty0 console=ttyS0,115200"
initrd /boot/initramfs-virt

After mounting boot media the sequence should continue to reach a login 
prompt.

I've run the hypervisor over ssh as well as on the tty, the results are 
the same. I would appreciate any suggestions..

---

From: Miguel Angel Rivera Notararigo <[email-masked]>
Date: Tue, 19 Jan 2021 08:06:10 -0400

Could you try removing `console=tty0 console=ttyS0,115200` when it is
booting? (maybe I am saying something stupid, but trying to help 😂)