Subject: [alpine-user] Zerotier

From: Tristan Kohl <[email-masked]>
Date: Sat, 16 Feb 2019 20:20:38 +0100

Hey guys,

does anybody know when (or if ever) there will be a Zerotier package in
the Alpine repositories? From what I can see in aports repository it has
been in testing since end '16 and last update was August '18. What
triggers a move to official repos - I figure time is not the answer here?

Today I tried running the docker image from zerotier but Alpine 3.9
barks at me for there being no '/dev/net/tun'.

Any advice/insights on those topics?

Cheers,
Tristan

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Adam Růžička <[email-masked]>
Date: Sat, 16 Feb 2019 21:37:39 +0000

Hey,

> Alpine 3.9 barks at me for there being no '/dev/net/tun'.

Did you have all the necessary things configured for the container?
For the container to be able to configure tunnels it needs to have
/dev/net/tun present (--device /dev/net/tun) and have
the NET_ADMIN capability (--cap-add=NET_ADMIN)

-- Adam

On Sat, Feb 16, 2019 at 8:20 PM Tristan Kohl <[email-masked]<mailto:[email-masked]>> wrote:
Hey guys,

Cheers,
Tristan

---
Unsubscribe:  [email-masked]<mailto:[email-masked]>
Help:         [email-masked]<mailto:[email-masked]>
---