Subject: [alpine-user] alpine 3.6 /usr/bin/wish

From: Achim <[email-masked]>
Date: Mon, 17 Jul 2017 15:38:42 +0200

Hi,

I'm using alpine:3.6 and installed Tcl/TK with
  apk add tcl tk

tcl works, wish starts fine showing the default empty window.
But adding any graphical object causes a seg. dump:

	# echo 'pack [label .b -text fail]'|wish
	Segmentation fault (core dumped)
	#

(has nothing to do with STDIN or alike, same problem if started from a file).

Any help would be appreciated.
Achim

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Cág <[email-masked]>
Date: Mon, 24 Jul 2017 19:18:55 +0100

Hi,

Sorry for the late reply. Have you solved your problem yet? If not,
please send the backtrace.

I am using edge now, and the command works here.

-- 
caóc

---

---

From: Achim <[email-masked]>
Date: Mon, 24 Jul 2017 22:01:52 +0200

Hi,

same problem with edge.
I guess that the missing X11 libraries are the reason. I did not install
any.
If so, I can live with that, as I found a way to call the wish script on
the host talking to the tools in the docker image. Not really what I want
but better than instaling huge X11 in the image.
Thanks.
--
Achim

---

---

From: Jean-Louis Fuchs <[email-masked]>
Date: Mon, 24 Jul 2017 23:50:44 +0200

Hi

> but better than instaling huge X11 in the image.

There is xvfb, which is "headless" X11, used in tools like VNC. It
should be much smaller than X11.

Best,
    Jean-Louis

---

From: Achim <[email-masked]>
Date: Tue, 25 Jul 2017 00:42:02 +0200

> should be much smaller than X11.

works with xvfb, both 3.6 and edge.
It nearly doubles my image in size, but if someone wants that, here we go;-)

Thanks
Achim

---