Subject: no xterm?

From: Riccardo Mottola <[email-masked]>
Date: Thu, 26 Nov 2020 22:31:26 +0100

Hi

According to:

https://pkgs.alpinelinux.org/packages?name=xterm&branch=v3.12

xterm exists in 3.12!

In my repostories I have:

#/media/cdrom/apks
http://dl-8.alpinelinux.org/alpine/v3.12/main
http://dl-4.alpinelinux.org/alpine/v3.12/main
#http://dl-8.alpinelinux.org/alpine/v3.12/community

Yet when I install it:
~$ sudo apk add xterm
ERROR: unsatisfiable constraints:
   xterm (missing):
     required by: world[xterm]

So where is the issue here?

Riccardo

---

From: Thomas Reid <[email-masked]>
Date: Fri, 27 Nov 2020 10:52:20 +0000

Hi,
You will find that xterm is in the community repo.

> #http://dl-8.alpinelinux.org/alpine/v3.12/community

You will have to enable the community repo, which is currently 
commented out.
Uncomment it, run `apk update` and then you should be able to install.

All the best,
Tom

---

From: Riccardo Mottola <[email-masked]>
Date: Wed, 9 Dec 2020 12:49:07 +0100

Hi!

> Uncomment it, run `apk update` and then you should be able to install.

That's indeed the fix. Also dl-8 is apparently not available so I 
changed it to dl-4.

It was just unexpected to me to think "xterm" is not part of main.

Riccardo