Subject: Incus setup instructions?

From: Kaj Wiik <[email-masked]>
Date: Sun, 14 Jul 2024 11:50:43 +0300

Hi!

It seems that setting up is a bit different in Alpine than in e.g. 
Ubuntu, is there any instructions how to set up incus in Alpine.

Specifically, I get an error

Error: Failed to connect to local daemon: Get "http://unix.socket/1.0": 
dial unix /var/lib/incus/unix.socket: connect: no such file or directory

when trying to run
incus admin init

Thanks,
Kaj

---

From: Unicorn <[email-masked]>
Date: Sun, 14 Jul 2024 11:07:18 +0200 (GMT+02:00)

Hi!

Did you start the incusd service before running this command? After 
starting incusd it worked just fine for me on a few Alpine systems.

Best,
Edin

---

From: Kaj Wiik <[email-masked]>
Date: Sun, 14 Jul 2024 12:16:00 +0300

Ha!

That was it! So running

rc-service incusd start

did it!

Many thanks Edin!

Cheers,
Kaj

On 14.7.2024 12.07, Unicorn wrote:
>> Error: Failed to connect to local daemon: Get 
>> "http://unix.socket/1.0": dial unix /var/lib/incus/unix.socket: 
>> connect: no such file or directory
>>
>> when trying to run
>> incus admin init
>>
>> Thanks,
>> Kaj

---

From: Unicorn <[email-masked]>
Date: Sun, 14 Jul 2024 11:48:19 +0200 (GMT+02:00)

> Kaj

No problem, happy to hear it works!

Best,
Edin