Subject: Re: [alpine-user] Alpine Failed to Boot up the Raspberry Pi 3 B+

From: Tyler A <[email-masked]>
Date: Mon, 25 Mar 2019 06:01:38 +0000

I'm having the same problem with the Raspberry Pi 2.

I set it up according to https://wiki.alpinelinux.org/wiki/Raspberry_Pi

As you can see:

Disk /dev/mmcblk0: 7.4 GiB, 7948206080 bytes, 15523840 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x2b2dd466

Device         Boot Start      End  Sectors  Size Id Type
/dev/mmcblk0p1 *     2048 15523839 15521792  7.4G  c W95 FAT32 (LBA)

$ sudo file -sL /dev/mmcblk0p1
/dev/mmcblk0p1: DOS/MBR boot sector, code offset 0x58+2, OEM-ID
"mkfs.fat", sectors/cluster 8, Media descriptor 0xf8, sectors/track 16,
heads 4, hidden sectors 2048, sectors 15521792 (volumes > 32 MB), FAT
(32 bit), sectors/FAT 15136, serial number 0x352b8981, unlabeled

I am able to run Alpinelinux 3.9.0, but not 3.9.1 or 3.9.2.

When attempting to boot I just get a blank screen. The LED blinks 6
times for me, then repeats another 6 times.

-- 
Tyler (tya99)
rsa4096/0x9C9954F88E388859

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: "Brent B. Powers" <[email-masked]>
Date: Mon, 25 Mar 2019 12:54:43 -0400

Just as a point of verification, I've the same set of issues. At first I'd
thought it had to do with the upgrade from 3.8, but at this point I've been
unable to get 3.9.2 properly booting on a 3 or 0 in any way.

---

From: Tyler A <[email-masked]>
Date: Tue, 26 Mar 2019 00:39:32 +0000

On 25/3/19 4:54 pm, Brent B. Powers wrote:
> Just as a point of verification, I've the same set of issues. At first
> I'd thought it had to do with the upgrade from 3.8, but at this point
> I've been unable to get 3.9.2 properly booting on a 3 or 0 in any way.

At this point I think we will open a bug on the tracker as it appears
something is wrong.

https://bugs.alpinelinux.org/issues/10155

---

---

From: Tyler A <[email-masked]>
Date: Tue, 26 Mar 2019 10:32:33 +0000

> I've been unable to get 3.9.2 properly booting on a 3 or 0 in any way.

Okay so I have  Raspberry Pi 2 B, which has:

# cat /proc/cpuinfo
processor	: 0
model name	: ARMv7 Processor rev 5 (v7l)
BogoMIPS	: 38.40
Features	: half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt
vfpd32 lpae evtstrm
CPU implementer	: 0x41
CPU architecture: 7
CPU variant	: 0x0
CPU part	: 0xc07
CPU revision	: 5

processor	: 1
model name	: ARMv7 Processor rev 5 (v7l)
BogoMIPS	: 38.40
Features	: half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt
vfpd32 lpae evtstrm
CPU implementer	: 0x41
CPU architecture: 7
CPU variant	: 0x0
CPU part	: 0xc07
CPU revision	: 5

processor	: 2
model name	: ARMv7 Processor rev 5 (v7l)
BogoMIPS	: 38.40
Features	: half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt
vfpd32 lpae evtstrm
CPU implementer	: 0x41
CPU architecture: 7
CPU variant	: 0x0
CPU part	: 0xc07
CPU revision	: 5

processor	: 3
model name	: ARMv7 Processor rev 5 (v7l)
BogoMIPS	: 38.40
Features	: half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt
vfpd32 lpae evtstrm
CPU implementer	: 0x41
CPU architecture: 7
CPU variant	: 0x0
CPU part	: 0xc07
CPU revision	: 5

Hardware	: BCM2835
Revision	: a21041

I tried the armv7 image and that worked. Maybe if you're on the
Raspberry Pi 3 you should try the aarch64 image, I think aarch64 is more
optimized than armhf for Pi 3 (which is 64bit).

https://stackoverflow.com/questions/37790029/what-is-difference-between-arm64-and-armhf

---