Subject: pam_cap.so missing from libcap

From: daggs <[email-masked]>
Date: Sat, 6 Jul 2024 22:24:00 +0200

Greetings,

I've noticed the mentioned above file is missing from libcap.
is there a specific reason for that?
taking the tar file, unpacking it and running compile locally generated the relevant file but the build log doesn't show
it gets built and there is not patch to disable it, I wonder how it is get disabled?

Thanks,

Dagg

---

From: donoban <[email-masked]>
Date: Sun, 7 Jul 2024 10:05:30 +0000

On Sat, Jul 06, 2024 at 10:24:00PM UTC, daggs wrote:
Hi,

> it gets built and there is not patch to disable it, I wonder how it is get disabled?

It seems that it auto detects PAM based on this Make.Rules line:

PAM_CAP ?= $(shell if [ -f /usr/include/security/pam_modules.h ]; then echo $(SHARED) ; else echo no ; fi)

Since PAM support is opt-in in Alpine it probably doesn't exist on
builders.

---

From: daggs <[email-masked]>
Date: Sun, 7 Jul 2024 20:17:07 +0200

> Sent: Sunday, July 07, 2024 at 1:05 PM
> From: "donoban" <[email-masked]>
> To: ~alpine/[email-masked]
> Subject: Re: pam_cap.so missing from libcap
>

thanks, installing linux-pam-dev on my miniroot and then building libcap fixes the issue