Mail archive
alpine-devel

[alpine-devel] Recommend "hold to kamailio 1.5.3" for Alpine 1.10 release

From: Nathan Angelacos <nangel_at_nothome.org>
Date: Thu, 21 Jan 2010 17:11:45 -0800

Got a chance to test kamailio 3.0 from edge today


It starts, but has serious flaws:

As compiled, the config file was moved from /etc/kamailio/kamailio.cfg to
/usr/etc/kamailio/kamailio.cfg

As compiled, the modules are stored in
/usr/lib/kamailio/modules and
/usr/lib/kamailio/modules_k


Manually moving all the modules to /usr/lib/kamailio/modules got
kamailio to at least check the config file.

A production config file from 1.5.3 failed with syntax errors (keywords
missing)


Since kamailio 1.5.3 is stable and in production in many environments,
and kamailio 3.0.0 has been out for only a week, I recommend we keep
kamailio 3.0.0 in "edge" and use 1.5.3 for the continuing 1.9 / 1.10
stable release.

If you cannot have 3.0.0 in "edge", then recommend dropping it from the
repository until 3.0.1 is released.





---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Thu Jan 21 2010 - 17:11:45 UTC