~alpine/devel

2

[alpine-devel] "rc is deprecated" warnings on fresh 3.4 install

Alba Pompeo
Details
Message ID
<CAJDAfTA3a245Sy07xB+Qm3pAnP73G46+DBsoDNdvONDOEwZSeA@mail.gmail.com>
Sender timestamp
1465230670
DKIM signature
missing
Download raw message
I've just installed Alpine 3.4 (fresh) and no other packages.
Upong shutdown, i prints this message (twice).
"rc is deprecated, please use openrc instead."

Ciao!


---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---

[alpine-devel] Re: "rc is deprecated" warnings on fresh 3.4 install

Alba Pompeo
Details
Message ID
<CAJDAfTD4hNmSYNN6MKy-WqFCSEzm-yZT2p5pUASZxW2fmmeU6A@mail.gmail.com>
In-Reply-To
<CAJDAfTA3a245Sy07xB+Qm3pAnP73G46+DBsoDNdvONDOEwZSeA@mail.gmail.com> (view parent)
Sender timestamp
1465251062
DKIM signature
missing
Download raw message
The solution is to change line 22 from ::shutdown:/sbin/rc shutdown
to   ::shutdown:/sbin/openrc shutdown
https://github.com/JuliaLang/julia/issues/16792

Ciao!


On Mon, Jun 6, 2016 at 1:31 PM, Alba Pompeo <albapompeo@gmail.com> wrote:
> I've just installed Alpine 3.4 (fresh) and no other packages.
> Upong shutdown, i prints this message (twice).
> "rc is deprecated, please use openrc instead."
>
> Ciao!


---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---

[alpine-devel] Re: "rc is deprecated" warnings on fresh 3.4 install

Alba Pompeo
Details
Message ID
<CAJDAfTDydDPW0_Qp_hy+Hn1tKJoSRJGMDV4KKzJg1w4iPV7D+A@mail.gmail.com>
In-Reply-To
<CAJDAfTD4hNmSYNN6MKy-WqFCSEzm-yZT2p5pUASZxW2fmmeU6A@mail.gmail.com> (view parent)
Sender timestamp
1465318895
DKIM signature
missing
Download raw message
Fixed on http://git.alpinelinux.org/cgit/aports/commit/?id=48a669f23fbe328c072c2d8783cce95d125c470b
It would be good if this fix was also added to the 3.4 stable branch.
Thanks.



On Mon, Jun 6, 2016 at 7:11 PM, Alba Pompeo <albapompeo@gmail.com> wrote:
> The solution is to change line 22 from ::shutdown:/sbin/rc shutdown
> to   ::shutdown:/sbin/openrc shutdown
> https://github.com/JuliaLang/julia/issues/16792
>
> Ciao!
>
>
> On Mon, Jun 6, 2016 at 1:31 PM, Alba Pompeo <albapompeo@gmail.com> wrote:
>> I've just installed Alpine 3.4 (fresh) and no other packages.
>> Upong shutdown, i prints this message (twice).
>> "rc is deprecated, please use openrc instead."
>>
>> Ciao!


---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---