For discussion of Alpine Linux development and developer support

4 3

[alpine-devel] rEFInd, Alpine, and luks

Etienne
Details
Message ID
<e6be48d6-dda5-7220-a333-314079a5a517@magickarpet.org>
Sender timestamp
1505571979
DKIM signature
missing
Download raw message
Hello list,

I am booting Alpine on a laptop via rEFInd off an encrypted volume 
(LUKS), and it works fine, but I hit a minor annoyance: the password 
prompt doesn't show up, even if the system is waiting for one. I suspect 
this is related to how/when the screen is refreshing or changing 
resolution during the booting process. As a result, I need to wait for 
"a certain time", enter my password blindly, and hope I haven't entered 
it too early.

I have recorded a video to help with the description: 
https://youtu.be/mvAlxsDeeDs

Despite searching on Web, I couldn't find a reference of someone running 
into the same issue, so I'm asking here: Any suggestion on what to do 
next to fix this?

Some distributions show a splash screen and prompt for a password to 
decrypt the volume after, and I suspect this refreshes the screen in a 
manner that would sort this issue. Any idea how to do that with Alpine?

Thanks for reading.

-- 
Étienne



---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---
Bruno d'Arcangeli
Details
Message ID
<20170916154817.c3vqck36etcwc72l@arcangeli.org>
In-Reply-To
<e6be48d6-dda5-7220-a333-314079a5a517@magickarpet.org> (view parent)
Sender timestamp
1505576897
DKIM signature
missing
Download raw message
Le Saturday 16 Sep 2017 à 15:26:19 (+0100), Etienne a écrit:
> Hello list,
> 
> I am booting Alpine on a laptop via rEFInd off an encrypted volume (LUKS),
> and it works fine, but I hit a minor annoyance: the password prompt doesn't
> show up, even if the system is waiting for one. I suspect this is related to
> how/when the screen is refreshing or changing resolution during the booting
> process. As a result, I need to wait for "a certain time", enter my password
> blindly, and hope I haven't entered it too early.
> 
> I have recorded a video to help with the description:
> https://youtu.be/mvAlxsDeeDs
> 
> Despite searching on Web, I couldn't find a reference of someone running
> into the same issue, so I'm asking here: Any suggestion on what to do next
> to fix this?

You may try to boot your kernel with the "nomodeset" option. For adding
it to rEFInd:
https://wiki.archlinux.org/index.php/REFInd#Passing_kernel_parameters

-- 
Blog ARM à la sauce Linux ultra légère:
http://www.arcangeli.org
Etienne
Details
Message ID
<3e4bc63b-67bb-d5b8-99e8-425b11119b4f@magickarpet.org>
In-Reply-To
<20170916154817.c3vqck36etcwc72l@arcangeli.org> (view parent)
Sender timestamp
1505659695
DKIM signature
missing
Download raw message
On 16/09/17 16:48, Bruno d'Arcangeli wrote:
> Le Saturday 16 Sep 2017 à 15:26:19 (+0100), Etienne a écrit:
>> I have recorded a video to help with the description:
>> https://youtu.be/mvAlxsDeeDs
>>
>> Despite searching on Web, I couldn't find a reference of someone running
>> into the same issue, so I'm asking here: Any suggestion on what to do next
>> to fix this?
> You may try to boot your kernel with the "nomodeset" option. For adding
> it to rEFInd:
> https://wiki.archlinux.org/index.php/REFInd#Passing_kernel_parameters
>
Ah, thanks, but although it's not visible in the video, I have already 
tried that, with no difference in the result.

-- 
Étienne



---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---

Re: [alpine-devel] [solved] rEFInd, Alpine, and luks

Kevin Gallagher
Details
Message ID
<7cc2a6a6-2985-f5f1-fe25-3ad2aac12532@gmail.com>
In-Reply-To
<51634a02-3176-e506-9793-8ef1a38234c3@magickarpet.org> (view parent)
Sender timestamp
1505688567
DKIM signature
missing
Download raw message
Still suggests there's a bug somewhere...


On 09/17/2017 03:46 PM, Etienne wrote:
> On 17/09/17 15:48, Etienne wrote:
>> On 16/09/17 16:48, Bruno d'Arcangeli wrote:
>>> Le Saturday 16 Sep 2017 à 15:26:19 (+0100), Etienne a écrit:
>>>> I have recorded a video to help with the description:
>>>> https://youtu.be/mvAlxsDeeDs
>>>>
>>>> Despite searching on Web, I couldn't find a reference of someone
>>>> running
>>>> into the same issue, so I'm asking here: Any suggestion on what to
>>>> do next
>>>> to fix this?
>>> You may try to boot your kernel with the "nomodeset" option. For adding
>>> it to rEFInd:
>>> https://wiki.archlinux.org/index.php/REFInd#Passing_kernel_parameters
>>>
>> Ah, thanks, but although it's not visible in the video, I have
>> already tried that, with no difference in the result.
>>
> Sorry, replying to myself here. This seems to be tied to the hardware
> I was testing on (a Lenovo x120e), I can't reproduce the issue on a
> different laptop.
>
> Thanks for reading anyway.
>



---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---

Re: [alpine-devel] [solved] rEFInd, Alpine, and luks

Etienne
Details
Message ID
<51634a02-3176-e506-9793-8ef1a38234c3@magickarpet.org>
In-Reply-To
<3e4bc63b-67bb-d5b8-99e8-425b11119b4f@magickarpet.org> (view parent)
Sender timestamp
1505688371
DKIM signature
missing
Download raw message
On 17/09/17 15:48, Etienne wrote:
> On 16/09/17 16:48, Bruno d'Arcangeli wrote:
>> Le Saturday 16 Sep 2017 à 15:26:19 (+0100), Etienne a écrit:
>>> I have recorded a video to help with the description:
>>> https://youtu.be/mvAlxsDeeDs
>>>
>>> Despite searching on Web, I couldn't find a reference of someone 
>>> running
>>> into the same issue, so I'm asking here: Any suggestion on what to 
>>> do next
>>> to fix this?
>> You may try to boot your kernel with the "nomodeset" option. For adding
>> it to rEFInd:
>> https://wiki.archlinux.org/index.php/REFInd#Passing_kernel_parameters
>>
> Ah, thanks, but although it's not visible in the video, I have already 
> tried that, with no difference in the result.
>
Sorry, replying to myself here. This seems to be tied to the hardware I 
was testing on (a Lenovo x120e), I can't reproduce the issue on a 
different laptop.

Thanks for reading anyway.

-- 
Étienne



---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---